Closed Bug 1213136 Opened 4 years ago Closed 4 years ago

Brotli fails to build on big endian

Categories

(Core :: Layout: Text and Fonts, defect)

44 Branch
Other
Unspecified
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla44
Tracking Status
firefox44 --- fixed

People

(Reporter: stevensn, Assigned: stevensn)

References

Details

Attachments

(1 file, 1 obsolete file)

Brotli fails to build on big endian machines

This is likely following https://hg.mozilla.org/mozilla-central/rev/8881708f5c15
for bug 1207298

---
 ../../dist/include/./bit_reader.h:184:22: error: BrotliPullByte was not declared in this scope
63:44.23      BrotliPullByte(br);
Attached patch 1213136.patch (obsolete) — Splinter Review
The upstream commit fixes this issue
https://github.com/google/brotli/commit/9ceff0372cad4236bb2b8b6cc8d2621cfa0ea058
but that is a more involved commit that I wouldn't want to manually patch in

I think we could also swap the order of BrotliFillBitWindow and BrotliPullByte
Attachment #8671728 - Flags: review?(mcmanus)
Comment on attachment 8671728 [details] [diff] [review]
1213136.patch

Review of attachment 8671728 [details] [diff] [review]:
-----------------------------------------------------------------

can you run that patch through a full set of try builds, and also note the patch in modules/brotli/README.mozilla (also noting that a fix is already upstream so we don't need to worry about losing it when we sync again).

with all of that done r+. thanks!
Attachment #8671728 - Flags: review?(mcmanus) → review+
Attached patch 1213136.patchSplinter Review
Patch updated with the README update
Assignee: nobody → steve
Attachment #8671728 - Attachment is obsolete: true
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/ee4cb52e6b15
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Duplicate of this bug: 1213108
You need to log in before you can comment on or make changes to this bug.