Excessive spacing for account/folder selection submenus in context menu in Retina displays

RESOLVED FIXED in Thunderbird 60.0

Status

defect
RESOLVED FIXED
4 years ago
Last year

People

(Reporter: floss, Assigned: Paenglab)

Tracking

38 Branch
Thunderbird 60.0
x86_64
macOS

Thunderbird Tracking Flags

(thunderbird_esr52 fixed, thunderbird59 wontfix, thunderbird60 fixed)

Details

(Whiteboard: TB 52.7 ESR)

Attachments

(6 attachments)

Reporter

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150929144111

Steps to reproduce:

On OS X 10.9 or 10.11:
Right-click on a message in the message list pane, select "Move To" or "Copy To" from the context menu, and then select one of the mail accounts.


Actual results:

Submenu items for mail accounts and for folders which contain subfolders – anything with a submenu under it – take up twice the vertical space as normal menu items. This takes up more screen real estate, and causes irregular menu item spacing in folders where the child items are a mix of folders which do and do not contain subfolders.


Expected results:

Menu item spacing should be the same as a normal menu item or submenu item, like the "Forward As", "Tag", and "Mark" items in the top context menu.
Reporter

Updated

4 years ago
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
Unable to reproduce on OS X 10.11 and latest trunk.

Do you see the same problem with add-ons -e.g. themes- disabled, Andrew?
Flags: needinfo?(floss)
Reporter

Comment 2

4 years ago
I don't have any Thunderbird add-ins installed. 

Still happening for me on Tb 42.0b1 on OS X 10.11.1 beta. Attaching a screenshot; note how the "B" folder and its parents take more vertical space than the leaf folders "A", C", etc.

Is there somewhere I can download a nightly build from the latest trunk to test out?
Flags: needinfo?(floss)
Mac builds should be on http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central/, but lately there has not been any successfull build, so you would not find any there, only Linux and Windows ones.

But, if you are able to test -and willing to-, I am going to build my own copy of the repository and package the result in a .DMG so you could check it. It will install as Daily -the name they chose instead of Nightly.

I am packaging it now, I will post a new answer with the link so you can grab it.
Reporter

Comment 4

4 years ago
Sure, I'll test off your build. I have an isolated system and set of accounts for testing, so I'm not paranoid about where the builds come from.
Reporter

Comment 6

4 years ago
Reporter

Comment 7

4 years ago
Javi: the extra spacing is still happening for me with that custom Daily build you posted. Looks just like the 42.0b1 for me.

You know what, this looks like a Retina display issue. All the shots so far have been from Retina MacBook Pros. I also tried it on an older non-Retina MacBook Pro, and the spacing issue does not happen there. (Attaching comparative screenshots.) The vertical alignment of text within the menu item cell looks off - too high, like what happened on Yosemite before the theme for that version was fully defined - but all the menu item cells are the same size.
Reporter

Comment 9

4 years ago
Or possibly it's a difference between OS X 10.11.0 and 10.11.1. The non-Retina MacBook has not been upgraded to 10.11.1 beta yet. When I find a few hours, I'll rebuild all my test boxes as 10.11 non-beta and separate 10.11.1 beta VMs, to remove that variable.
Summary: Excessive spacing for account/folder selection submenus in context menu → Excessive spacing for account/folder selection submenus in context menu in Retina displays
Still an issue with newer version?
Component: Untriaged → Account Manager
Flags: needinfo?(floss)
Flags: needinfo?(e.berberich)
Assignee

Comment 11

Last year
I'm seeing it too with Daily.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(floss)
Flags: needinfo?(e.berberich)
I'm still seeing the issue with Daily in the "Recent" drop down menu (attachment)
Assignee

Comment 14

Last year
Philipp, you are one of the few Mac developers. Please could you check this patch?

I hope, you have a Retina Mac, then it's very obvious with the spacing. But also with a normal Mac you see the effect: Without patch, all menu arrows with the folder icons are slightly moved to the right compared to the normal ones like the "Recent" menu arrow. With patch they are correctly aligned.
Attachment #8954447 - Flags: review?(philipp)
Comment on attachment 8954447 [details] [diff] [review]
Mac-menu-arrow.patch

Review of attachment 8954447 [details] [diff] [review]:
-----------------------------------------------------------------

I have a retina mac and this does seem to fix it for me, r=philipp
Attachment #8954447 - Flags: review?(philipp) → review+
Assignee

Comment 16

Last year
Thanks.
Keywords: checkin-needed

Comment 17

Last year
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/a6f508bc1053
Define a image width/height for the folderMenuItem's menu arrow. r=philipp
Status: ASSIGNED → RESOLVED
Closed: Last year
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

Last year
Target Milestone: --- → Thunderbird 60.0
Assignee

Comment 18

Last year
Comment on attachment 8954447 [details] [diff] [review]
Mac-menu-arrow.patch

This raised already pre 52 and ESR52 is supported until August. So it makes sense to fix this there too.
Attachment #8954447 - Flags: approval-comm-esr52?
Attachment #8954447 - Flags: approval-comm-beta?
I doubt that we're doing another TB 59 beta.
Comment on attachment 8954447 [details] [diff] [review]
Mac-menu-arrow.patch

Already in TB 60 going to beta soon.
Attachment #8954447 - Flags: approval-comm-beta?

Updated

Last year
Attachment #8954447 - Flags: approval-comm-esr52? → approval-comm-esr52+
You need to log in before you can comment on or make changes to this bug.