Firefox blocks flash because it thinks it's out of date

UNCONFIRMED
Unassigned

Status

()

P4
normal
UNCONFIRMED
3 years ago
a year ago

People

(Reporter: zilla, Unassigned)

Tracking

41 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.101 Safari/537.36

Steps to reproduce:

Try to view a page with a Flash plugin.




Actual results:

Firefox tells me it's out of date. The plugin check page says I have version 11.2.202.508 but that's wrong, I have version flash-plugin-11.2.202.521-release.x86_64 installed.

This happens ALL THE TIME, and the only way I know to fix it is to manually update the pluginreg.dat file with the correct version number.

Incorrect pluginreg.dat entry:

libflashplayer.so:$
/usr/lib64/flash-plugin/libflashplayer.so:$
11.2.202.508:$
1440563451000:0:0:0:$
Shockwave Flash 11.2 r202:$
Shockwave Flash:$
2
0:application/x-shockwave-flash:Shockwave Flash:swf:$
1:application/futuresplash:FutureSplash Player:spl:$




Expected results:

Firefox should know what version of Flash I have and stop blocking me from using it.
Component: Untriaged → Plug-ins
Product: Firefox → Core

Comment 1

3 years ago
If you simply delete pluginreg.dat does this automatically fix itself? If not, it's likely that the plugin is reporting the wrong data to Firefox.

How are you updating Flash? Firefox checks the timestamp of the plugin against the timestamp stored in pluginreg.dat and should invalidate the cache if it detects a timestamp mismatch. If your update process doesn't change the timestamp that could also cause this kind of issue.
Flags: needinfo?(zilla)
(Reporter)

Comment 2

3 years ago
I haven't tried deleting that file, because I didn't know that would be safe and it would be recreated.

I update flash via yum (or dnf now), using the .repo file from https://get.adobe.com/flashplayer/otherversions/
Flags: needinfo?(zilla)
(Reporter)

Comment 3

3 years ago
I very much doubt that the update doesn't change the timestamp.

Comment 4

3 years ago
Yes me too, but I've seen stranger things. Can you try deleting pluginreg.dat and seeing what gets regenerated at next startup?
(Reporter)

Comment 5

3 years ago
pluginreg.dat had the right version in already (I don't know if I'd corrected it manually or it just got it right this time). Deleting it and restarting firefox recreates it with the right version string.

Next time it goes wrong I'll try recreating it again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

3 years ago
This is happening again. Firefox says I have 11.2.202.577 but that's wrong:

$ ls -l /usr/lib64/flash-plugin/libflashplayer.so
-rwxr-xr-x. 1 root root 19294272 Apr  5 10:19 /usr/lib64/flash-plugin/libflashplayer.so
libstdc++-v3$ rpm -qi flash-plugin
Name        : flash-plugin
Version     : 11.2.202.616
Release     : release
Architecture: x86_64
Install Date: Fri 08 Apr 2016 11:07:30 BST
Group       : Applications/Internet
Size        : 20406387
License     : Commercial
Signature   : DSA/SHA1, Tue 05 Apr 2016 18:35:42 BST, Key ID 3a69bd24f6777c67
Source RPM  : flash-plugin-11.2.202.616-release.src.rpm
Build Date  : Tue 05 Apr 2016 10:19:49 BST
Build Host  : frbuild-lnx-bran64
Relocations : (not relocatable)
Packager    : Adobe Systems Inc.
Vendor      : Adobe Systems Inc.
URL         : http://www.adobe.com/downloads/
Summary     : Adobe Flash Player 11.2
Description :
Adobe Flash Plugin 11.2.202.616
Fully Supported: Mozilla SeaMonkey 1.0+, Firefox 1.5+, Mozilla 1.7.13+

$ ls -l pluginreg.dat 
-rw-------. 1 jwakely jwakely 1216 Apr 21 13:13 pluginreg.dat

The pluginreg.dat file contains:

libflashplayer.so:$
/usr/lib64/flash-plugin/libflashplayer.so:$
11.2.202.577:$
1459847984000:0:0:0:$
Shockwave Flash 11.2 r202:$
Shockwave Flash:$
2
0:application/x-shockwave-flash:Shockwave Flash:swf:$

The timestamp in the file matches the mtime of the plugin (2016-04-05 10:19:44) but the version is wrong. That suggests Firefox is not correctly updating the info in pluginreg.dat

If I delete the file and restart Firefox then it is recreated with the correct version, but that should not be necessary every time I update the plugin.


Could there be a race condition when the plugin is updated, where Firefox uses the timestamp from the new file, but queries the version from the existing plugin .so which is already linked into the process?
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 7

3 years ago
Yes, there could be. Especially on Linux DLL loading is weird. Is Flash being updated while Firefox is running!?
Priority: -- → P4
(Reporter)

Comment 8

3 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #7)
> Yes, there could be. Especially on Linux DLL loading is weird. Is Flash
> being updated while Firefox is running!?

Yes, I keep Firefox running most of the time, I never close it to apply updates. That's probably what most people do.

Comment 9

3 years ago
Replacing a shared library while Firefox is using it is unlikely to work. On other platforms, the way Flash updates work is that they used numbered library names: NPSWF32_12_0_0_198.dll and an upgrade changes the name. That should work on Linux.

I'm inclined to WONTFIX this and ask either Adobe or your Linux distro to fix the upgrade scheme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 10

3 years ago
I'm not asking for Firefox to start using the new plugin, it makes perfect sense that it doesn't pickup the change until Firefox is restarted. But it shouldn't update the timestamp in the pluginreg.dat file so that it then fails to notice a new version when it *does* restart.

That's just dumb. "Ooh, a new file, let's get the info from it .. except we get the info from the old version, and then update our config to make it look like it came from the new one". That is clearly a bug in Firefox - it's your code that detects the timestamp change and updates Firefox's own config with false metadata.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
(Reporter)

Comment 11

3 years ago
How about not updating the info in pluginreg.dat if doing so reliably on linux is impossible?

Just do it on restart instead. There will still be a small window for a race condition, if the plugin gets updated while firefox is restarting, but it will be *much* smaller, since people run firefox for days or weeks without restart, and the time spent restarting is a tiny fraction of that.

Comment 12

2 years ago
Since Firefox just blocked a bunch of Flash 24 versions now that 25 is released, a bunch of Linux users including me are getting confusing messages where Firefox is reporting that the Flash plugin is out of date - even though we have upgraded flash and restarted Firefox. (I'm using Fedora 25, with flash installed from Adobe's yum repository)

Like the original reporter, deleting the pluginreg.dat works around the issue, but I had to do some searching to figure out the problem (and there's a lot of other confused users out there all the way back to the firefox 3 days...)

There's a longstanding note about this in the mozillazine knowledge base too: http://kb.mozillazine.org/Issues_related_to_plugins
"Note: In some cases, the pluginreg.dat file and the about:plugins list may contain outdated information, even after a restart. To refresh the list, close your Mozilla application and delete (or rename) the "pluginreg.dat" file in the Firefox profile folder or SeaMonkey profile folder. A new pluginreg.dat file will be generated when you restart the browser"

A commenter on https://bugzilla.mozilla.org/show_bug.cgi?id=942356 appears to have seen this issue during a flash 11.2 to 24 update as well.

Updated

a year ago
Duplicate of this bug: 1189157

Updated

a year ago
Duplicate of this bug: 1277349

Updated

a year ago
Summary: Firefox blocks flash because it thinks it's out of date → Firefox blocks flash because it thinks it's out of date - using stale pluginreg because the Flash shared library doesn't change its timestamp

Updated

a year ago
Duplicate of this bug: 1365766
(Reporter)

Comment 16

a year ago
"using stale pluginreg because the Flash shared library doesn't change its timestamp"

That's not true, the timestamp absolutely does change when upgrading it using the official Adobe RPM. Stop trying to blame this on the plugin.

The problem is that Firefox uses the version info from the OLD plugin that is already loaded in memory, and the timestamp from the NEW plugin, that was updated on disk. 

Here is the plugin I have installed:

$ rpm -qi flash-plugin
Name        : flash-plugin
Version     : 26.0.0.126
Release     : release
Architecture: x86_64
Install Date: Wed 14 Jun 2017 09:50:04 BST
Group       : Applications/Internet
Size        : 20916713
License     : Commercial
Signature   : DSA/SHA1, Sat 10 Jun 2017 01:43:10 BST, Key ID 3a69bd24f6777c67
Source RPM  : flash-plugin-26.0.0.126-release.src.rpm
Build Date  : Fri 09 Jun 2017 23:44:24 BST
Build Host  : frtubt-jnkns7
Relocations : (not relocatable)
Packager    : Adobe Systems Inc.
Vendor      : Adobe Systems Inc.
URL         : http://www.adobe.com/downloads/
Summary     : Adobe Flash Player NPAPI
Description :
Adobe Flash Plugin 26.0.0.126
$ rpm -ql flash-plugin | fgrep .so
/usr/lib64/flash-plugin/libflashplayer.so
/usr/lib64/kde4/kcm_adobe_flash_player.so
$ ls -l /usr/lib64/flash-plugin/libflashplayer.so
-rwxr-xr-x. 1 root root 16480480 Jun  9 23:44 /usr/lib64/flash-plugin/libflashplayer.so

The new version was installed on Jun 9, and the timestamp matches the installation time.

Here's the version info Firefox has:

$ grep -A 10 PLUGINS ~/.mozilla/firefox/*/pluginreg.dat
[PLUGINS]
libflashplayer.so:$
/usr/lib64/flash-plugin/libflashplayer.so:$
25.0.0.171:$
1497048257000:0:0:0:$
Shockwave Flash 25.0 r0:$
Shockwave Flash:$
2
0:application/x-shockwave-flash:Shockwave Flash:swf:$
1:application/futuresplash:FutureSplash Player:spl:$


The version 25.0.0.171 is the old version, but the date is the installation date of the new version:

$ date --date='@1497048257'
Fri  9 Jun 23:44:17 BST 2017
Summary: Firefox blocks flash because it thinks it's out of date - using stale pluginreg because the Flash shared library doesn't change its timestamp → Firefox blocks flash because it thinks it's out of date
(Reporter)

Comment 17

a year ago
(In reply to Jonathan Wakely from comment #16)
> The new version was installed on Jun 9, and the timestamp matches the
> installation time.

Correction, it was installed on June 14, but it was built (by Adobe) on June 9, and the timestamp of the file is June 9 (because the RPM preserves the timestamp from the packager's build).

That doesn't change anything though: Firefox is still updating its pluginreg.dat with the new timestamp of the file, but not updating the version info to correspond to that file.

The old file was installed the previous month, so would not have a timestamp of June 9. The 25.0.0.171 package was released a month earlier:
https://helpx.adobe.com/security/products/flash-player/apsb17-15.html


Every time the plugin gets updated on disk Firefox updates its pluginreg.dat to record the new timestamp, but keeps the old version string. This is not a problem with the plugin. You can see this happening:

$ ls -l ~/.mozilla/firefox/*/pluginreg.dat
-rw-------. 1 jwakely jwakely 543 Jun 14 17:57 /home/jwakely/.mozilla/firefox/86ihtpjx.default/pluginreg.dat
$ 
$ grep -A 10 PLUGINS ~/.mozilla/firefox/*/pluginreg.dat
[PLUGINS]
libflashplayer.so:$
/usr/lib64/flash-plugin/libflashplayer.so:$
25.0.0.171:$
1497048257000:0:0:0:$
Shockwave Flash 25.0 r0:$
Shockwave Flash:$
2
0:application/x-shockwave-flash:Shockwave Flash:swf:$
1:application/futuresplash:FutureSplash Player:spl:$

libstdc++-v3$ su - 
Password: 
[root ~]# touch /usr/lib64/flash-plugin/libflashplayer.so 
[root ~]# logout
$ 
$ ls -l /usr/lib64/flash-plugin/libflashplayer.so
-rwxr-xr-x. 1 root root 16480480 Jun 14 18:11 /usr/lib64/flash-plugin/libflashplayer.so
$ 
$ grep -A 10 PLUGINS ~/.mozilla/firefox/*/pluginreg.dat
[PLUGINS]
libflashplayer.so:$
/usr/lib64/flash-plugin/libflashplayer.so:$
25.0.0.171:$
1497048257000:0:0:0:$
Shockwave Flash 25.0 r0:$
Shockwave Flash:$
2
0:application/x-shockwave-flash:Shockwave Flash:swf:$
1:application/futuresplash:FutureSplash Player:spl:$

$ 
$ date --date='@1497048257'
Fri  9 Jun 23:44:17 BST 2017
$ 
$ # not changed
$ # wait a few minutes for firefox to notice the touched file
$ 
$ ls -l ~/.mozilla/firefox/*/pluginreg.dat
-rw-------. 1 jwakely jwakely 543 Jun 14 18:14 /home/jwakely/.mozilla/firefox/86ihtpjx.default/pluginreg.dat
$ 
$ grep -A 10 PLUGINS ~/.mozilla/firefox/*/pluginreg.dat
[PLUGINS]
libflashplayer.so:$
/usr/lib64/flash-plugin/libflashplayer.so:$
25.0.0.171:$
1497460308000:0:0:0:$
Shockwave Flash 25.0 r0:$
Shockwave Flash:$
2
0:application/x-shockwave-flash:Shockwave Flash:swf:$
1:application/futuresplash:FutureSplash Player:spl:$

$ date --date='@1497460308'
Wed 14 Jun 18:11:48 BST 2017

Firefox has updated the timestamp, but kept the old version info.
(Reporter)

Comment 18

a year ago
And just to prove the old timestamp from the old version isn't June 9 (even though that old version was installed long before that date) here is the file from the archived 25.0.0.171 release, downloaded from https://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html

fp$ unzip fp_25.0.0.171_archive.zip 
Archive:  fp_25.0.0.171_archive.zip
   creating: 25_0_r0_171/
  inflating: 25_0_r0_171/flashplayer25_0r0_171_linux.i386.tar.gz  
  inflating: 25_0_r0_171/flashplayer25_0r0_171_linux.x86_64.tar.gz  
  inflating: 25_0_r0_171/flashplayer25_0r0_171_linux_sa.x86_64.tar.gz  
  inflating: 25_0_r0_171/flashplayer25_0r0_171_linuxpep.i386.tar.gz  
  inflating: 25_0_r0_171/flashplayer25_0r0_171_linuxpep.x86_64.tar.gz  
  inflating: 25_0_r0_171/flashplayer25_0r0_171_mac.dmg  
  inflating: 25_0_r0_171/flashplayer25_0r0_171_mac_pkg.dmg  
  inflating: 25_0_r0_171/flashplayer25_0r0_171_mac_sa.dmg  
  inflating: 25_0_r0_171/flashplayer25_0r0_171_macpep.dmg  
  inflating: 25_0_r0_171/flashplayer25_0r0_171_macpep_pkg.dmg  
  inflating: 25_0_r0_171/flashplayer25_0r0_171_win.exe  
  inflating: 25_0_r0_171/flashplayer25_0r0_171_win.msi  
  inflating: 25_0_r0_171/flashplayer25_0r0_171_win_sa.exe  
  inflating: 25_0_r0_171/flashplayer25_0r0_171_winax.exe  
  inflating: 25_0_r0_171/flashplayer25_0r0_171_winax.msi  
  inflating: 25_0_r0_171/flashplayer25_0r0_171_winpep.exe  
  inflating: 25_0_r0_171/flashplayer25_0r0_171_winpep.msi  
  inflating: 25_0_r0_171/uninstall_flashplayer25_0r0_171_mac.dmg  
  inflating: 25_0_r0_171/uninstall_flashplayer25_0r0_171_win.exe  
   creating: 25_0_r0_171_debug/
  inflating: 25_0_r0_171_debug/flashplayer25_0r0_171_linux_debug.i386.tar.gz  
  inflating: 25_0_r0_171_debug/flashplayer25_0r0_171_linux_debug.x86_64.tar.gz  
  inflating: 25_0_r0_171_debug/flashplayer25_0r0_171_linux_sa_debug.x86_64.tar.gz  
  inflating: 25_0_r0_171_debug/flashplayer25_0r0_171_linuxpep_debug.x86_64.tar.gz  
  inflating: 25_0_r0_171_debug/flashplayer25_0r0_171_mac_debug.dmg  
  inflating: 25_0_r0_171_debug/flashplayer25_0r0_171_mac_sa_debug.dmg  
  inflating: 25_0_r0_171_debug/flashplayer25_0r0_171_macpep_debug.dmg  
  inflating: 25_0_r0_171_debug/flashplayer25_0r0_171_win_debug.exe  
  inflating: 25_0_r0_171_debug/flashplayer25_0r0_171_win_sa_debug.exe  
  inflating: 25_0_r0_171_debug/flashplayer25_0r0_171_winax_debug.exe  
  inflating: 25_0_r0_171_debug/flashplayer25_0r0_171_winpep_debug.exe  
fp$ tar tvf 25_0_r0_171/flashplayer25_0r0_171_linux.x86_64.tar.gz
-rw-rw-r-- soluser/soluser 16464096 2017-04-27 05:43 libflashplayer.so
-rw-rw-r-- soluser/soluser     3617 2017-04-27 05:43 readme.txt
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 LGPL/
-rw-rw-r-- soluser/soluser     7402 2017-04-27 05:43 LGPL/LGPL.txt
-rw-rw-r-- soluser/soluser       76 2017-04-27 05:43 LGPL/notice.txt
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/share/
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/share/kde4/
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/share/kde4/services/
-rw-rw-r-- soluser/soluser     4354 2017-04-27 05:43 usr/share/kde4/services/kcm_adobe_flash_player.desktop
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/share/pixmaps/
lrwxrwxrwx soluser/soluser        0 2017-04-27 05:43 usr/share/pixmaps/flash-player-properties.png -> ../icons/hicolor/48x48/apps/flash-player-properties.png
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/share/applications/
-rw-rw-r-- soluser/soluser      968 2017-04-27 05:43 usr/share/applications/flash-player-properties.desktop
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/share/icons/
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/share/icons/hicolor/
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/share/icons/hicolor/32x32/
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/share/icons/hicolor/32x32/apps/
-rw-rw-r-- soluser/soluser      863 2017-04-27 05:43 usr/share/icons/hicolor/32x32/apps/flash-player-properties.png
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/share/icons/hicolor/16x16/
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/share/icons/hicolor/16x16/apps/
-rw-rw-r-- soluser/soluser      473 2017-04-27 05:43 usr/share/icons/hicolor/16x16/apps/flash-player-properties.png
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/share/icons/hicolor/48x48/
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/share/icons/hicolor/48x48/apps/
-rw-rw-r-- soluser/soluser     1256 2017-04-27 05:43 usr/share/icons/hicolor/48x48/apps/flash-player-properties.png
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/share/icons/hicolor/22x22/
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/share/icons/hicolor/22x22/apps/
-rw-rw-r-- soluser/soluser      653 2017-04-27 05:43 usr/share/icons/hicolor/22x22/apps/flash-player-properties.png
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/share/icons/hicolor/24x24/
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/share/icons/hicolor/24x24/apps/
-rw-rw-r-- soluser/soluser      656 2017-04-27 05:43 usr/share/icons/hicolor/24x24/apps/flash-player-properties.png
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/lib/
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/lib/kde4/
lrwxrwxrwx soluser/soluser        0 2017-04-27 05:43 usr/lib/kde4/kcm_adobe_flash_player.so -> /usr/lib64/kde4/kcm_adobe_flash_player.so
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/bin/
-rwxr-xr-x soluser/soluser   706528 2017-04-27 05:43 usr/bin/flash-player-properties
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/lib64/
drwxrwxr-x soluser/soluser        0 2017-04-27 05:43 usr/lib64/kde4/
-rwxr-xr-x soluser/soluser   912104 2017-04-27 05:43 usr/lib64/kde4/kcm_adobe_flash_player.so
-rw-rw-r-- soluser/soluser  2792147 2017-04-27 05:43 license.pdf

Note the date of the old libflashplayer.so file is 2017-04-27
(Reporter)

Comment 19

a year ago
Adobe just released a new flash-plugin, so I could watch Firefox mess things up in realtime, as I installed the plugin.

The first thing I did was quit firefox, then remove pluginreg.dat, and restart Firefox. This ensured it had the correct info for the plugin, not the bogus info shown in my previous comments. So I started from a good state.

tmp$ # check timestamp of current plugin
tmp$ ls -l /usr/lib64/flash-plugin/libflashplayer.so
-rwxr-xr-x. 1 root root 16480480 Jun 14 18:11 /usr/lib64/flash-plugin/libflashplayer.so
tmp$ 
tmp$ 
tmp$ # check contents of pluginreg.dat
tmp$ grep -A 10 PLUGIN ~/.mozilla/firefox/*.default/pluginreg.dat
[PLUGINS]
libflashplayer.so:$
/usr/lib64/flash-plugin/libflashplayer.so:$
26.0.0.126:$
1497460308000:0:0:0:$
Shockwave Flash 26.0 r0:$
Shockwave Flash:$
2
0:application/x-shockwave-flash:Shockwave Flash:swf:$
1:application/futuresplash:FutureSplash Player:spl:$

tmp$ 
tmp$ date --date=@1497460308
Wed 14 Jun 18:11:48 BST 2017
tmp$ 
tmp$ rpm -q flash-plugin
flash-plugin-26.0.0.126-release.x86_64
tmp$ 
tmp$ # so pluginreg.dat has correct version and correct timestamp
tmp$ 
tmp$ 
tmp$ sudo dnf  update flash-plugin
enabling rpmfusion-free-debuginfo repository
enabling rpmfusion-free-updates-debuginfo repository
enabling updates-debuginfo repository
enabling fedora-cisco-openh264-debuginfo repository
enabling fedora-debuginfo repository
Last metadata expiration check: 0:01:14 ago on Sat Jun 17 13:17:33 2017.
Dependencies resolved.
==================================================================================================================================================================================================================
 Package                                          Arch                                       Version                                                 Repository                                              Size
==================================================================================================================================================================================================================
Upgrading:
 flash-plugin                                     x86_64                                     26.0.0.131-release                                      adobe-linux-x86_64                                     8.6 M

Transaction Summary
==================================================================================================================================================================================================================
Upgrade  1 Package

Total download size: 8.6 M
Is this ok [y/N]: y
Downloading Packages:
flash-player-npapi-26.0.0.131-release.x86_64.rpm                                                                                                                                  6.4 MB/s | 8.6 MB     00:01    
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                                             6.4 MB/s | 8.6 MB     00:01     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Upgrading   : flash-plugin-26.0.0.131-release.x86_64                                                                                                                                                        1/2 
  Cleanup     : flash-plugin-26.0.0.126-release.x86_64                                                                                                                                                        2/2 
  Verifying   : flash-plugin-26.0.0.131-release.x86_64                                                                                                                                                        1/2 
  Verifying   : flash-plugin-26.0.0.126-release.x86_64                                                                                                                                                        2/2 

Upgraded:
  flash-plugin.x86_64 26.0.0.131-release                                                                                                                                                                          

Complete!
tmp$ 
tmp$ tmp$ rpm -q flash-plugin
flash-plugin-26.0.0.131-release.x86_64
tmp$ 
tmp$ ls -l /usr/lib64/flash-plugin/libflashplayer.so
-rwxr-xr-x. 1 root root 16480480 Jun 15 00:46 /usr/lib64/flash-plugin/libflashplayer.so
tmp$ 
tmp$ 
tmp$ # wait a bit, open about:plugins in firefox, recheck:
tmp$ grep -A 10 PLUGIN ~/.mozilla/firefox/*.default/pluginreg.dat
[PLUGINS]
libflashplayer.so:$
/usr/lib64/flash-plugin/libflashplayer.so:$
26.0.0.126:$
1497483977000:0:0:0:$
Shockwave Flash 26.0 r0:$
Shockwave Flash:$
2
0:application/x-shockwave-flash:Shockwave Flash:swf:$
1:application/futuresplash:FutureSplash Player:spl:$

tmp$ 
tmp$ 
tmp$ date --date=@1497483977
Thu 15 Jun 00:46:17 BST 2017
tmp$ 

So firefox changed the timestamp to the mtime of the new libflashplayer.so but didn't update the version from 26.0.0.126 to 26.0.0.131

Is this enough to demonstrate the problem is in Firefox and not due to the timestamp of the flash plugin?
(Reporter)

Comment 20

a year ago
I still think the suggestion in comment 11 would be a huge improvement, with no downside.
You need to log in before you can comment on or make changes to this bug.