[RTL][First Time Experience]On FTE PIN view, the Back icon on title, the cursor in the input area and text typed into the input area are not right-aligned.

VERIFIED FIXED

Status

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: yue.xia, Assigned: autra)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.5 verified, b2g-master verified)

Details

(Whiteboard: [2.5-rtl-test-run])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8671816 [details]
Aries2.5&Flame2.5_FTE_PIN page.png

[1.Description]:
[RTL][Aries KK v2.5][Flame KK v2.5][First Time Experience]On FTE PIN view, the Back icon on title, the cursor in the input area and text typed into the input area are not right-aligned.
See attachment: Aries2.5&Flame2.5_FTE_PIN page.png

[2.Testing Steps]: 
1. Insert a SIM cards with PIN code in device and set your phone language to Arabic in FTE. 
2. Tap "Next" button in FTE Language page. 
3. Observe the enter PIN view. 


[3.Expected Result]: 
3.1 The back button should be right-aligned and mirrored. 
3.2 The cursor in the input area should be right-aligned and text typed into the input area should be right-aligned.

[4.Actual Result]: 
3.1 The Back icon on title are not right-aligned.
3.2 The cursor in the input area is left-aligned and text typed into the input area are left-aligned.

[5.Reproduction build]: 
Device: Aries KK v2.5 (Affected)
Build ID               20151008233852
Gaia Revision          e698df503ff700eb5782e3d50c6eb753567d3451
Gaia Date              2015-10-08 17:26:52
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/23b7f289df923c01e692299fcd4be7029de8b155
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151008.225742
Firmware Date          Thu Oct  8 22:57:51 UTC 2015
Bootloader             s1

Device: Flame KK v2.5 (Affected)
Build ID               20151008150210
Gaia Revision          e698df503ff700eb5782e3d50c6eb753567d3451
Gaia Date              2015-10-08 17:26:52
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e5f1bc63ad52d0eb86f7fb838226ca6036774660
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151008.182756
Firmware Date          Thu Oct  8 18:28:08 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
15449
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact]
status-b2g-master: --- → affected
(Reporter)

Updated

3 years ago
Blocks: 1207259

Updated

3 years ago
Whiteboard: [2.5-rtl-test-run]
(Assignee)

Updated

3 years ago
Assignee: nobody → augustin.trancart
(Assignee)

Updated

3 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

3 years ago
I cannot reproduce the issue with the input area (both for cursor and text typed). It should have been fixed by the refactoring of input areas.

For the back icon, it will be fixed by bug 1213226: the header were LTR-forced because navigations weren't mirrored yet. This bug will remove this.

NI myself to close this bug once bug 1213226 lands.
Flags: needinfo?(augustin.trancart)
No longer blocks: 1207259
(Assignee)

Comment 2

3 years ago
FIXED by the patch for bug 1213226
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(augustin.trancart)
Resolution: --- → FIXED
(Reporter)

Comment 3

3 years ago
Created attachment 8684863 [details]
Verify_FlameKKv2.5.png

This problem is verified as pass on latest build of Aries KK 2.5/v2.6 and Flame KK v2.5/v2.6 by STR in comment 0.
Actual results: The back button is right-aligned and mirrored. The cursor in the input area is right-aligned and text typed into the input area is right-aligned too.
See attachment: Verify_FlameKKv2.5.png
Reproduce rate: 0/10

Device: Aries KK 2.5 (Pass)
Build ID               20151107112205
Gaia Revision          577948202ae12154524a2bd2bd6d467838ad50b8
Gaia Date              2015-11-07 10:00:59
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/ae7b8b1fd9e1504347b938820f99d75058049386
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151107.104119
Firmware Date          Sat Nov  7 10:41:27 UTC 2015
Bootloader             s1

Device: Aries KK 2.6 (master) (Pass)
Build ID               20151107001102
Gaia Revision          c3436122d678911d04b8f491724596116890ff9b
Gaia Date              2015-11-06 18:22:03
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e2a910c048dc82fc3be53475f18e7f81f03e377b
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151106.232924
Firmware Date          Fri Nov  6 23:29:32 UTC 2015
Bootloader             s1

Device: Flame KK 2.5 512MB (Pass)
Build ID               20151108004501
Gaia Revision          577948202ae12154524a2bd2bd6d467838ad50b8
Gaia Date              2015-11-07 10:00:59
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/ae7b8b1fd9e1504347b938820f99d75058049386
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151108.045623
Firmware Date          Sun Nov  8 04:56:35 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.6 512mb (master) (Pass)
Build ID               20151108150206
Gaia Revision          c3436122d678911d04b8f491724596116890ff9b
Gaia Date              2015-11-06 18:22:03
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e2a910c048dc82fc3be53475f18e7f81f03e377b
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151108.183921
Firmware Date          Sun Nov  8 18:39:33 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
(Reporter)

Updated

3 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
status-b2g-v2.5: --- → verified
status-b2g-master: affected → verified
You need to log in before you can comment on or make changes to this bug.