firefox displays web page without any formatting but other browsers do

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: cflav, Unassigned)

Tracking

41 Branch
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8671845 [details]
Screen Shot 2015-10-09 at 13.10.44.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150929144111

Steps to reproduce:

I visited the following page:
http://www.lanuovaprimapagina.it/


Actual results:

the page is shown without formatting, as if CSS stylesheets were not loaded or applied (see attached picture)


Expected results:

opening the same page with Safari doesn't show any issues
(Reporter)

Comment 1

3 years ago
Created attachment 8671846 [details]
screen shot of the page rendered by Safari

Comment 2

3 years ago
I get the same problem with Yahoo pages -- Yahoo Finance and Yahoo Mail. Here's an example page from Yahoo Finance: http://finance.yahoo.com/echarts?s=INTC+Interactive#{%22range%22:%221d%22,%22allowChartStacking%22:true}

The pages render fine in IE.

I think this only started happening when I installed the latest Firefox update about two days ago (i.e. around 10/19, 10/20).
Component: Untriaged → General
OS: Unspecified → Mac OS X

Comment 3

3 years ago
(In reply to bootmagna from comment #2)
> I get the same problem with Yahoo pages -- Yahoo Finance and Yahoo Mail.
> Here's an example page from Yahoo Finance:
> http://finance.yahoo.com/echarts?s=INTC+Interactive#{%22range%22:%221d%22,
> %22allowChartStacking%22:true}
> 
> The pages render fine in IE.
> 
> I think this only started happening when I installed the latest Firefox
> update about two days ago (i.e. around 10/19, 10/20).

Update: I found the pages can be made to format properly by disabling Privacy Badger (an anti-tracking add-in from Electronic Frontier Foundation) on Yahoo pages.
Hello Flavio,

I was unable to reproduce with the following specs:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:45.0) Gecko/20100101 Firefox 42.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:45.0) Gecko/20100101 Firefox 45.0

Are you still having this issue?
Flags: needinfo?(cflav)
Component: General → Layout
Product: Firefox → Core
(Reporter)

Comment 5

3 years ago
Hi Grover,
no, apparently it went away after installing Firefox 42.0

Cheers
Flavio
Flags: needinfo?(cflav)
Likely some stylesheet was getting blocked or failing to download for some reason. In any case, sounds like it's working now, so maybe we'll never know.  Resolving as WORKSFORME per comment 5.

Thanks for filing, in any case! (and thanks Grover for the triage)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.