ensure up-to-date npm modules at the start of run-all-loop-tests.sh

RESOLVED DUPLICATE of bug 1232030

Status

P3
normal
Rank:
35
RESOLVED DUPLICATE of bug 1232030
3 years ago
3 years ago

People

(Reporter: dmose, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tech-debt])

User Story

As a developer, my npm dependencies should stay up to date as a result of my normal workflow, so that I don't waste time debugging version mismatches.

Acceptance Criteria:

* executing run-all-loop-tests.sh should automatically update the dependencies

Tech checklist

* add "update" target to standalone/Makefile which runs "npm update" in standalone and standalone/../test
* remove code in run-all-loop-tests.sh that checks for missing dirs and blows up
* add code to beginning of run-all-loop-tests.sh to invoke the make target
Comment hidden (empty)

Updated

3 years ago
Rank: 35
Priority: -- → P3
This has been fixed in the new loop repo via https://github.com/mozilla/loop/pull/11 / bug 1232030.

As we won't be fixing this for mozilla-central, I'm marking this as a duplicate of that bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1232030
You need to log in before you can comment on or make changes to this bug.