The default bug view has changed. See this FAQ.

Facebook loads faster from Google search results in Chrome

RESOLVED DUPLICATE of bug 730101

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 730101
2 years ago
a year ago

People

(Reporter: vladan, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [content perf][necko-active])

(Reporter)

Description

2 years ago
STR:
1. Navigate to google.com
2. Search for term “facebook”
3. Pause for a moment, then click on the top result (facebook.com)
4. Compare Facebook load time & loading appearance in Chrome vs Firefox

Video: https://www.dropbox.com/s/l7injr1i6e8u0sx/content_perf3_fb_on_3_browsers.flv?dl=0

Notes:

* This was discovered on the content-perf test laptop: HP Pavillion 14t i3-5010u on a stock “HP Recommended” (balanced) power profile (plugged in), with wired connection to office LAN
* We suspect this is because of pre-rendering, but this needs to be confirmed
* This finding does not generalize to all Google search results (need to figure out why)
(Reporter)

Updated

2 years ago
Blocks: 1213469
(In reply to Vladan Djeric (:vladan) -- please needinfo from comment #0)
> * We suspect this is because of pre-rendering, but this needs to be confirmed

Can you see Chrome's prerendering process active? 

> * This finding does not generalize to all Google search results (need to
> figure out why)

They have heuristics about when to prerender a page (ie. when to inject the link rel=prerender) based on confidence you'll click it, etc.
Flags: needinfo?(vladan.bugzilla)
(Reporter)

Updated

a year ago
Flags: needinfo?(vladan.bugzilla) → needinfo?(avihpit)
(In reply to Andrew Overholt [:overholt] from comment #1)
> (In reply to Vladan Djeric (:vladan) -- please needinfo from comment #0)
> > * We suspect this is because of pre-rendering, but this needs to be confirmed
> 
> Can you see Chrome's prerendering process active? 

The experiments were limited to observations of browser behavior, and the observation here was that clicking the facebook search result ended up with practically instant navigation and display of the page.

We didn't try to analyze which processes are involved and how.

Basically, it's what you can see at the video on comment 0, put into words.
Flags: needinfo?(avihpit)
valentin, I think as part of presto you should look at this case..
Flags: needinfo?(valentin.gosu)
Whiteboard: [content perf] → [content perf][necko-active]
I can confirm that this is caused by prerendering in Chrome.
1. the page load is instantaneous
2. facebook.com shows up in chrome://net-internals/#prerender and is marked as Used
GWS Prerender	https://www.facebook.com/	Used	2016-03-03 19:05:05.054
Flags: needinfo?(valentin.gosu)
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 730101
You need to log in before you can comment on or make changes to this bug.