Firefox shouldn’t change tab title to “Connecting…” whenever a page issues a network request

RESOLVED FIXED in Firefox 46

Status

()

Firefox
Tabbed Browser
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: vladan, Assigned: Dolske)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 46
Points:
---

Firefox Tracking Flags

(firefox46 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
STR:
1. Load a Facebook profile page. I used my friend’s, oddly enough this does not reproduce on all Facebook profile pages
2. Scroll down to the bottom of the profile to trigger fetching of additional profile contents

Expected: Chrome only shows the page-loading spinner during network requests, Edge and IE don’t change the tab area at all

Actual: Firefox shows the spinner and repeatedly changes the page title to
“Connecting...” which is bad UX imho

Video: https://www.dropbox.com/s/hk1w09c4j3x1vvt/connecting_bug.mp4?dl=0
(Reporter)

Comment 1

2 years ago
phlsa, what do you think?
Flags: needinfo?(philipp)
(Reporter)

Updated

2 years ago
Blocks: 1213469

Comment 2

2 years ago
The fact that chrome does it differently doesn't matter much here IMO, but the fact that you (vlad) find it distracting does.

However, I don't think there's a right or wrong here since it's a personal preference. For instance, I like that Firefox spins the throbber when it accesses the network, and it's also an indication for why the page cannot be scrolled further while further data is being fetched (most pages have their own in-page "throbber thingy for that", but not all).

Bottom line, it's not black and white IMO that it shouldn't spin while fetching data from the network.
(Reporter)

Comment 3

2 years ago
This is really a question for UX, which is why I needinfo'd phlsa.

Note also that this bug report is about the tab title repeatedly getting changed to "Connecting..", not about the tab throbber
I think we should definitely get rid of the word »Connecting« in those cases. It doesn't add any value and it's a lot more distracting than the icon change.
The tab should just keep showing the page title.
Flags: needinfo?(philipp)
(Assignee)

Comment 5

2 years ago
Seems pretty obvious to me that the "Connecting…" text and connecting throbber should never be shown past initial page load. Although I'm not sure if there's some ancient reasoning for this, or if this is being caused by sub-resource / XHR loads leaking though to the top. First step here is probably looking at exactly why this is happening.

We can limit this bug to just "connecting", although I think that showing the busy throbber after initial pageload also isn't great. While it might be useful for something like infinite scroll being stalled, I'd expect there are many other uses of XHR where it's not. Like, if I'm just preloading some set of data in the background, showing the user a throbber is very much not useful. Not clear that there's any way for the browser to tell the difference. And then it starts to branch out into other areas... Is this really wanting to be a general network-activity indicator, and is a prominent throbber the right UI for that? What about JS activity?

Also, FWIW, there's been discussion of a spec to give sites that ability to control the indicator: see https://github.com/whatwg/fetch/issues/19 I'm not super keen on it, mostly because it means browser UI may seem inconsistent if some sites use it but others don't.

Dao/Gijs: Any thoughts here?
Flags: needinfo?(gijskruitbosch+bugs)
Flags: needinfo?(dao)
I think it's far less common that users need to wait for JS activity than for network requests, so it's not all that obvious to me that removing the throbber is a good idea. Note that we also show the status panel at the bottom of the window, which may or may not be enough feedback after the initial page load.

I do think "Connecting..." is unhelpful if not misleading. (We used to use "Loading..." as the label which I think made a bit more sense esp. after the initial page load.)
Flags: needinfo?(dao)

Comment 7

2 years ago
I concur with Dão and Philipp that we should get rid of "Connecting..." which is unhelpful as best.

I personally would not remove the spinner, but I recognize that I am a technical user, and it might not be super helpful for regular users. On the flip side, most websites have some loading indicator when they are waiting for content, and if other browsers don't show any indication of this then perhaps we shouldn't either.

(In reply to Dão Gottwald [:dao] from comment #6)
> Note that we also show the status panel at the
> bottom of the window, which may or may not be enough feedback after the
> initial page load.

FWIW, this does not consistently show up for me on the FB testcase from comment #1. Maybe because my network connection is too quick, maybe because we treat some requests differently from others - I'm not sure.


I think for this bug we should just get rid of Connecting...; we can always remove the spinner in another followup bug.
Flags: needinfo?(gijskruitbosch+bugs)
(Assignee)

Comment 8

2 years ago
Created attachment 8698214 [details] [diff] [review]
Patch v.1

This should restrict the "Connecting" text to top-level loads. Fixes the Facebook case for me.

(Jared last touched this in the vaguely-similar bug 709182.)
Assignee: nobody → dolske
Attachment #8698214 - Flags: review?(jaws)
Attachment #8698214 - Flags: review?(jaws) → review+
Keywords: checkin-needed

Comment 9

2 years ago
https://hg.mozilla.org/integration/fx-team/rev/d400505a9f12
Keywords: checkin-needed

Comment 10

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/d400505a9f12
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox46: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 46

Comment 11

2 years ago
Would you consider to remove the “Connecting…” title when restoring pending tabs

the tab title already set by SessionStore

Comment 12

2 years ago
(In reply to tabmix.onemen from comment #11)
> Would you consider to remove the “Connecting…” title when restoring pending
> tabs
> 
> the tab title already set by SessionStore

Please file a new bug for this.
You need to log in before you can comment on or make changes to this bug.