Memory not freed when browser is closed with quick-launch enabled

VERIFIED DUPLICATE of bug 106434

Status

Core Graveyard
QuickLaunch (AKA turbo mode)
VERIFIED DUPLICATE of bug 106434
16 years ago
5 years ago

People

(Reporter: Vineet Sinha, Assigned: Bill Law)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4)
Gecko/20011019 Netscape6/6.2
BuildID:    

When quick-launch is enabled, the memory usage of the minimized browser is lower
than when the browser is closed.

- tried with NS6.2 and Mozilla 0.9.7
- tried on Win2K

Reproducible: Always
Steps to Reproduce:
0. Enable quick-launch!
1. Start Moz., and then use TaskManager to note memory usage.
2. Minimize Moz. and note memory usage.
3. Restore Moz., then close it and note memory usage.


Actual Results:  Value from 2. is lesser than 3.

Expected Results:  3. should be lesser than 2.

My guess is that some memory clean-up happens when moz. is minimized (I would
guess some form of a garbage-collector). This memory clean-up does not happen
when moz. is closed.
this is already filed....
Assignee: trudelle → law
Component: XP Apps → QuickLaunch (AKA turbo mode)
QA Contact: sairuh → gbush
Whiteboard: DUPEME

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 106434 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME

Comment 3

16 years ago
verified
Status: RESOLVED → VERIFIED
Component: QuickLaunch (AKA turbo mode) → QuickLaunch (AKA turbo mode)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.