Closed Bug 1213499 Opened 4 years ago Closed 4 years ago

Enable H.264 MSE on Linux

Categories

(Core :: Audio/Video: Playback, defect, P1)

All
Linux
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox42 --- wontfix
firefox43 + fixed
firefox44 --- fixed
relnote-firefox --- 44+

People

(Reporter: cpeterson, Assigned: jya)

References

Details

Jean-Yves wants to uplift all ffmpeg-related changes to 43 and enable H.264 MSE on Linux.
I would (as a user) like this, but I don't have good context on any of the risks involved.
Priority: -- → P1
OS: All → Linux
Depends on: 1214943
Tracking this since it's part of a feature aimed for 43.
Release Note Request (optional, but appreciated)
[Why is this notable]: New feature for our GNU/Linux users
[Suggested wording]: H264 decoding available from the MSE API (GNU/Linux)
[Links (documentation, blog post, etc)]:
relnote-firefox: --- → ?
Jean-Yves - can we mark this as fixed?
Flags: needinfo?(jyavenard)
this is fixed by bug 1213173 and others
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(jyavenard)
Resolution: --- → FIXED
Should this be noted for 43 or for 44?  I just realized bug 1213173 is only fixed on 44.
Flags: needinfo?(jyavenard)
It should be in 43 too. 
I believe the fix went on there too (will confirm)

We will have to get 1219134 fixed and uplifted too.
Flags: needinfo?(jyavenard)
Release Note Request (optional, but appreciated)
[Why is this notable]: This change will allow Linux users to play H.264 video, which is a pretty big deal. This issue was fixed in 44 but uplifted to 43. I made bug 1219134 block this bug because Jean-Yves said (in comment 7) that fix must be uplifted to 43.
[Suggested wording]: Enable H.264 on Linux when FFmpeg is available.
[Links (documentation, blog post, etc)]:
Depends on: 1219134
Is this now fixed for 43 and 44? Or are there still some cleanup bugs coming?  If it's done now then can you mark the status for 43 and 44 ? Thanks :)
Flags: needinfo?(jyavenard)
Flags: needinfo?(jyavenard)
Wording updated to "Enable H.264 if system decoder is available"
You need to log in before you can comment on or make changes to this bug.