(B2G 2.5) "Merge duplicates" header is not localized

VERIFIED FIXED

Status

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: u547545, Assigned: arcturus)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [mozfr-community])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8672212 [details]
2015-10-10-09-12-07.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20151001180038

Steps to reproduce:

Tested with ZTE Open C (FR) and B2G 2.5 prerelease.

1) Set the phone to another language than English,
2) Open the application "Contacts",
3) Click on any contact,
4) Click on "Find duplicate contacts" (in "Organise Contacts"),


Actual results:

The header of the page is "Merge duplicates" (in English).

This translation error is found, whatever the language chosen at the start (other than English).


Expected results:

"Merge duplicates" should be translated into the selected language.

-----------
OS Version: 2.5.0.0-prerelease
Build Number: eng..20140806.064432
Platform Version: 44.0a1
Build Identifier: 201510010002247
Update Channel: nightly
Git Commit Info: 2015-10-09 21:39:30 (7f532564)
Bug 1188350 has landed 2 days ago and fixed the header (it was communication.gaiamobile before that), but didn't fix the l10n issue that had been reported in bug 1202356 initially.

Marking this bug block bug 1188350 and nominating for 2.5 so that it does not fall off of the radar.

[Blocking Requested - why for this release]: A visible part of the UI is not localized, we'll want to fix that before RA.
Blocks: 1188350
Status: UNCONFIRMED → NEW
blocking-b2g: --- → 2.5?
Ever confirmed: true
Summary: (B2G 2.5) Incorrect translation "Merge duplicates". → (B2G 2.5) "Merge duplicates" header is not localized
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Untranslated string, blocking.
blocking-b2g: 2.5? → 2.5+
Depends on: 1213553
Assignee: nobody → francisco
Status: NEW → ASSIGNED
Created attachment 8674228 [details] [review]
[gaia] arcturus:bug-1213539 > mozilla-b2g:master
Comment on attachment 8674228 [details] [review]
[gaia] arcturus:bug-1213539 > mozilla-b2g:master

Please review once bug 1213553 lands.
Attachment #8674228 - Flags: review?(ferjmoreno)
Attachment #8674228 - Flags: review?(ferjmoreno) → review+
Landed on master:

https://github.com/mozilla-b2g/gaia/commit/71c43389c417a2b9fec109659586ebc75f569549

and nga:

74f9978
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Verified in French with latest master on Aries

Build ID               20151016203810
Gaia Revision          f75a7e01912cee313fed92ff2089586f507b2ba5
Gaia Date              2015-10-16 13:00:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/01e37977f8da2e1f8b9ce9b777e556ffb1437960
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150903.154930
Firmware Date          Thu Sep  3 15:49:38 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
Created attachment 8675547 [details] [review]
[gaia] julienw:1213539-followup > mozilla-b2g:master
Comment on attachment 8675547 [details] [review]
[gaia] julienw:1213539-followup > mozilla-b2g:master

Hey Francisco,

please review this follow-up.
I also added unit tests to cover the code that was not covered... Honestly I had to rewrite a lot of them too, as the tests were interdependent...
Attachment #8675547 - Flags: review?(francisco)
See Also: → bug 1213553
Comment on attachment 8675547 [details] [review]
[gaia] julienw:1213539-followup > mozilla-b2g:master

Thanks, for the follow up, i tested it on the phone (both paths this time) and looking nice.
Attachment #8675547 - Flags: review?(francisco) → review+
Run the unit test locally since treeherder is busted and all of them are green,

merged:

https://github.com/mozilla-b2g/gaia/commit/fca30ed2012307a21111aabafb9e181a4f7a6c46

and nga:

b567e8e
(Reporter)

Updated

3 years ago
Whiteboard: [mozfr-community]
You need to log in before you can comment on or make changes to this bug.