[Aries KK][Contacts]When user creates two contacts with the same number, the Merge Duplicates view will be blank.

VERIFIED FIXED

Status

Firefox OS
Gaia::Contacts
--
major
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Carrie.Yang Leave from Mozilla, Assigned: julienw)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-aries-test-run-3])

Attachments

(6 attachments)

(Reporter)

Description

3 years ago
[1.Description]:
[Aries KK v2.5][Contacts]When user creates two contacts with the same number, the Merge Duplicates view will be blank and there isn't information and no button for merge.

Found time: 12:41
Attach: Aries KK_v2.5.3gp and logcat_1241.txt

[2.Testing Steps]: 
1. Launch Contacts app.
2. Create contact A with number.
3. Create contact B with the same number to merge.

[3.Expected Result]: 
3.The Merge Duplicates view should be shown correctly.

[4.Actual Result]: 
3. The Merge Duplicates view shows incorrectly, and there is no duplicate information in the upper position and no button at the bottom.

[5.Reproduction build]: 
Device: Flame KK 2.2 (Unaffected) 
Build ID               20151009032504
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/ab6c34bfacf7
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151009.064635
Firmware Date          Fri Oct  9 06:46:46 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5 (Unaffected)
Build ID               20151009150221
Gaia Revision          1609aecaba381c14eff95d5084e59280f53b7d8b
Gaia Date              2015-10-09 07:16:19
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c00e93135684441d065791f4f98a338b872d0420
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151009.183801
Firmware Date          Fri Oct  9 18:38:15 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Affected)
Build ID               20151010002512
Gaia Revision          74b0d4b17f39d238a7997800bd9363d3c60f20c3
Gaia Date              2015-10-09 19:27:39
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d1bb0de19476541cd517ab14017e7fedbd9f13e3
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151009.234251
Firmware Date          Fri Oct  9 23:42:59 UTC 2015
Bootloader             s1

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
9884

[8.NOTE]:
Enter the same characters in the same field (like this: Add Email, Name and Last name) in "Add contact" view, the bug can also repro.
(Reporter)

Comment 1

3 years ago
Created attachment 8672230 [details]
Aries KK_v2.5.3gp
(Reporter)

Comment 2

3 years ago
Created attachment 8672231 [details]
logcat_1241.txt
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Keywords: regression
[Blocking Requested - why for this release]: Functional regression
blocking-b2g: --- → 2.5?
blocking-b2g: 2.5? → 2.5+
Still wondering what could have changed in that code, asking fore regressionwindowwanted to have a clue of the possible candidates.
Keywords: regressionwindow-wanted
QA Contact: sleedavid
Comment hidden (obsolete)
B2G INBOUND regression window: 

Last Working: 
BuildID: 20151009003847
Device: Flame 2.5
BuildID: 20151009003847
Gaia: 1609aecaba381c14eff95d5084e59280f53b7d8b
Gecko: 16b558eac3e20d2d0c4c15f54b9105fa01ccc823
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

First Broken: 
BuildID: 20151009015347
Device: Flame 2.5
BuildID: 20151009015347
Gaia: c7df972bf6ac24769cc2f74a80c48dfaedcdb040
Gecko: c11e2ba8fb9c195624951083b723ec762bbd0d65
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Last Working Gaia First Broken Gecko - no repro
Gaia: 1609aecaba381c14eff95d5084e59280f53b7d8b
Gecko: c11e2ba8fb9c195624951083b723ec762bbd0d65

Last Working Gecko First Broken Gaia - repro
Gaia: c7df972bf6ac24769cc2f74a80c48dfaedcdb040
Gecko: 16b558eac3e20d2d0c4c15f54b9105fa01ccc823

GAIA Pushlog: 
https://github.com/mozilla-b2g/gaia/compare/1609aecaba381c14eff95d5084e59280f53b7d8b...c7df972bf6ac24769cc2f74a80c48dfaedcdb040

This issue is caused by changes made in Bug 1200576.
Gabriel this issue seems to have been caused by the changes for bug 1200576.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(gsvelto)
(Assignee)

Comment 8

3 years ago
I think I found the issue, taking.
Assignee: nobody → felash
Flags: needinfo?(gsvelto)
Status: NEW → ASSIGNED
Created attachment 8674264 [details] [review]
[gaia] julienw:1213553-merging-duplicates > mozilla-b2g:master
(Assignee)

Comment 10

3 years ago
Comment on attachment 8674264 [details] [review]
[gaia] julienw:1213553-merging-duplicates > mozilla-b2g:master

I updated the tests but did not activate them because I spent 3 hours on them without making them work properly. I asked jlorenzo to get support for switching iframes and I think we can resume work on the marionette tests after this. Too bad :(

FTR, the error was that sanitizer.js was not included in the Communications app after the change in bug 1200576, yet the merge interface needs it.
Attachment #8674264 - Flags: review?(francisco)
Unfortunately I don't think if marionette has the ability to change iframe yet, definitely something that will need to be fixed.
(Assignee)

Comment 12

3 years ago
It has the ability to change the activity (bug 1140344 landed recently) but it seems it doesn't work for the windows opened with window.open.
Comment on attachment 8674264 [details] [review]
[gaia] julienw:1213553-merging-duplicates > mozilla-b2g:master

LGTM, tried on the phone and working perfectly.

Thanks Julien!
Attachment #8674264 - Flags: review?(francisco) → review+
Hi,

Cannot reproduce this bug either with latest version of Flame or Aries devices.
Flame 2.5
Build ID: 20151016115545
Gaia: 8999f0ba

Aries 2.5
Build ID: 20151016120421
Gaia: 8999f0ba

Although as you can see in the video attached that green screen is shown for a little while.
Created attachment 8674969 [details]
VID_20151016_185623.3gp
(Assignee)

Comment 17

3 years ago
The green screen is shown for some time because we're launching a new window.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 18

3 years ago
Hi Irios,
    This bug can still be repro on latest build of flameKK v2.5 and AriesKK v2.5 by the STR in comment 0. I can repro it when the system language is in English, Arabic, Japanese, Portuguese and so on. Please see my video. 

    Could you please help to confirm again and reopen the bug if you can also repro it? thanks.
  

------------------------------------------------------------------------------------------------------
Actual results: The Merge Duplicates view shows incorrectly, and there is no duplicate information in the upper position and no button at the bottom.

See attachments: Aries KK_v2.5.3gp and logcat_1457.txt.
Reproduce rate: 10/10.

Device: Aries KK 2.5(Fail)
Build ID               20151018193102
Gaia Revision          f75a7e01912cee313fed92ff2089586f507b2ba5
Gaia Date              2015-10-16 13:00:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d1a89632277fbaaf470c90a35573776048988f2d
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151018.185054
Firmware Date          Sun Oct 18 18:51:02 UTC 2015
Bootloader             s1

Device: Flame KK 2.5(Fail)
Build ID               20151018150205
Gaia Revision          f75a7e01912cee313fed92ff2089586f507b2ba5
Gaia Date              2015-10-16 13:00:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d1a89632277fbaaf470c90a35573776048988f2d
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151018.183443
Firmware Date          Sun Oct 18 18:34:55 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Flags: needinfo?(irios.mozilla)
(Reporter)

Comment 19

3 years ago
Created attachment 8675536 [details]
Aries KK_v2.5.3gp
(Reporter)

Comment 20

3 years ago
Created attachment 8675537 [details]
logcat_1457.txt
This is weird, I can reproduce this bug again...
With both Aries and Flame.
Aries:
BuildID: 20151018190150
Gaia: f75a7e01
Flame:
BuildID: 20151018133001
Gaia: f75a7e01

I know is better not to reopen bugs, but since it seems to be happening the same..I am reopening, if you prefer otherwise, please close it and I will open a new one
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Hi Carrie, Yes, I was just commenting an reopening the bug.
On Friday it was ok, but something has changed again.
Thanks
Flags: needinfo?(irios.mozilla)
(Assignee)

Comment 23

3 years ago
This is because of the patch to bug 1213539 that has a typo, I'm writing a followup on that bug.
(Assignee)

Updated

3 years ago
See Also: → bug 1213539
Isabel, could you please verify this bug is fixed according to Julien's Comment #23 and close it please ?
Flags: needinfo?(irios.mozilla)
(Assignee)

Comment 25

3 years ago
Follow-up landed in bug 1213539, closing this bug now.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
I just checked with latest gaia (a87f947) and it is working fine. 
As soon as there is generated build including that fixes I will verify it.
Flags: needinfo?(irios.mozilla)
Verified.
Flame 2.5
Build ID: 20151019133017
Gaia:a87f9473

Aries 2.5
Build ID:20151019204321
Gaia: a87f9473
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.