Open Bug 1213604 Opened 4 years ago Updated 4 years ago

Left-floated content is shifted to far right, at jmp.com support page

Categories

(Core :: Layout: Floats, defect)

defect
Not set

Tracking

()

People

(Reporter: tkdubiel, Unassigned, NeedInfo)

References

()

Details

(Keywords: regression)

Attachments

(3 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20151010030234

Steps to reproduce:

Go to http://www.jmp.com/support/help/Join_Data_Tables.shtml


Actual results:

The page is not shown properly.


Expected results:

The page should be shown properly.
Site is shown properly here in Firefox 41. Cannot reproduce the problem.

For future reference, please read https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines and add a more useful description to this report. Thanks!
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
If "The page is not shown properly", please describe what that means. Or provide a screenshot.
Please also test with a fresh new profile and with any extensions/add-ons disabled.
"Site is shown properly here in Firefox 41." I wrote version of Firefox earlier - Firefox Nightly.
It is also bad displayed in latest Firefox Beta, also in safe mode, also with fresh profile. 
For future references, please carefully read information contained in the bug report.
Please don't so quickly make decisions about "cancelling" the bug, because this bug exists.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Today update didn't fix the problem.
Today update didn't fix the problem.
In the latest beta build (42.0b6) bug persists.
This bug exists all the time.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20151108030417

I can reproduce the issue on the latest Nightly. Setting the status of this bug to NEW.
Component: Untriaged → Layout: Block and Inline
Product: Firefox → Core
Version: 44 Branch → Other Branch
Status: UNCONFIRMED → NEW
Ever confirmed: true
Simona B, can you hunt down a regression range for this with mozregression, since this is clearly a regression between 41 and 42?
Flags: needinfo?(simona.marcu)
I've already got mozregression going; I'll have a range shortly.
Flags: needinfo?(simona.marcu)
Summary: Bad lay-out → Content is shifted way to the right, at jmp.com support page
mozilla-central regression range is:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=32712cd01159&tochange=5b54831761b1

Strongly suspect bug 538194, which had to do with float handling. (And the right-shifted content here is inside of a "float: left;" element, with id="left".
Blocks: 538194
Summary: Content is shifted way to the right, at jmp.com support page → Left-floated content is shifted to far right, at jmp.com support page
Inbound regression range confirms that this is a regression from bug 538194:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=838a7d98c1d41c2bf67497d0a80cca98a6001899&tochange=5dcb38c7f1b84d7fc4d0255a2b10165dfaceb941

(The other patches in that push are about transform/perspective & seem unlikely to be involved here.)

Tagging dbaron as needinfo. Also, a reduced testcase would likely help to isolate the problem, if anyone is up for trying to create a smaller testcase by hacking away at the jmp.com page. (Ideally the testcase should "work" in Chrome & old Firefox versions, but "break" in new Firefox versions).
Flags: needinfo?(dbaron)
Version: Other Branch → Trunk
Component: Layout: Block and Inline → Layout: Floats
Haven't reduced it down, but deleting the menu bar at the top ("JMP Software", "Using JMP",...) using the Inspector makes the main page content shift back to the center.
Attached file more reduced testcase (obsolete) —
Not all the way reduced yet, but it's a start. The offsetting appears tied to the list elements.
...except the mixed content blocker is blocking the external style sheet. *sigh*
This is basically the most-reduced I can get the page where there's still a rendering difference between Chrome and Firefox. That said, it renders the same in Firefox 41 and 42, so I'm not entirely sure it's the "right" testcase. Hopefully it helps.
Attachment #8684986 - Attachment is obsolete: true
Attachment #8685136 - Attachment description: reduced testcase → reduced testcase 1, for Chrome/Firefox difference (though not for Firefox 41/42 difference)
This testcase shows the difference between 41 and 42+. Interestingly, it also renders differently in Chrome. It might be possible to further-reduce this, but this is already pretty well-minimized and I don't intend to go any further with it.
It looks like the bug is fixed.
Perhaps the site has been fixed? I don't think Firefox's behavior changed here.

In particular, I can't reproduce the bug in old nightly 20151108030417, which was previously reported as reproducing the bug (comment 11).  And the attached reduced testcases render the same in current Nightly as they do in that old Nightly 20151108030417.
Yes, looks like the site changed to work around whatever issue we had. The attached testcases still show the behavior differences as described.
You need to log in before you can comment on or make changes to this bug.