Closed Bug 1213641 Opened 5 years ago Closed 5 years ago

|make installers-{LOCALE}| stage fails with mozbuild.preprocessor.Error: ('mozilla/extensions/irc/locales/generic/install.rdf', 12, 'UNDEFINED_VAR', 'MOZ_LANG_TITLE')

Categories

(SeaMonkey :: Build Config, defect, critical)

SeaMonkey 2.41 Branch
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 1210791

People

(Reporter: adriank, Unassigned)

References

Details

Getting this on all Linux and Windows platforms with c-c during |make installers-{LOCALE}| stage in case the LOCALE is also specified in ChatZilla's 'all-locales' file (if it's not, then make finishes successfully):

(...)
14:01:40 rm -f '../../../dist/xpi-stage/chatzilla-pl/install.rdf'
14:01:40 /home/mozilla/jenkins/workspace/seamonkey-central_linux64/objdir/_virtualenv/bin/python -m mozbuild.action.preprocessor --depend .deps/install.rdf.pp --silence-missing-directive-warnings -DXPI_NAME=chatzilla-pl -DAB_CD=pl -DNO_NSPR_10_SUPPORT -DAB_CD=pl -DINSTALL_EXTENSION_ID="langpack-pl@chatzilla.mozilla.org" -DCHATZILLA_VERSION=0.9.92 -DCHATZILLA_BASE_VERSION=0.9.92 -DHAVE_64BIT_BUILD='1' -DMOZ_ENABLE_PROFILER_SPS='1' -DMOZILLA_VERSION='"44.0a1"' -DMOZILLA_VERSION_U='44.0a1' -DMOZILLA_UAVERSION='"44.0"' -DXP_LINUX='1' -DD_INO='d_ino' -DMOZ_DEBUG_SYMBOLS='1' -DSTDC_HEADERS='1' -DHAVE_VISIBILITY_HIDDEN_ATTRIBUTE='1' -DHAVE_VISIBILITY_ATTRIBUTE='1' -DHAVE_DIRENT_H='1' -DHAVE_GETOPT_H='1' -DHAVE_SYS_BITYPES_H='1' -DHAVE_MEMORY_H='1' -DHAVE_UNISTD_H='1' -DHAVE_GNU_LIBC_VERSION_H='1' -DHAVE_NL_TYPES_H='1' -DHAVE_MALLOC_H='1' -DHAVE_X11_XKBLIB_H='1' -DHAVE_CPUID_H='1' -DHAVE_SYS_QUOTA_H='1' -DHAVE_SYS_SYSMACROS_H='1' -DHAVE_LINUX_QUOTA_H='1' -DHAVE_LINUX_IF_ADDR_H='1' -DHAVE_LINUX_RTNETLINK_H='1' -DHAVE_SYS_QUEUE_H='1' -DHAVE_SYS_TYPES_H='1' -DHAVE_NETINET_IN_H='1' -DHAVE_BYTESWAP_H='1' -DHAVE_DLOPEN='1' -DHAVE_DLADDR='1' -DHAVE_MEMMEM='1' -DFUNCPROTO='15' -DHAVE_LIBXSS='1' -D_REENTRANT='1' -DHAVE_PTHREAD_H='1' -DHAVE_STAT64='1' -DHAVE_LSTAT64='1' -DHAVE_TRUNCATE64='1' -DHAVE_GMTIME_R='1' -DHAVE_LOCALTIME_R='1' -DHAVE_CLOCK_MONOTONIC='1' -DHAVE_RES_NINIT='1' -DHAVE_LANGINFO_CODESET='1' -DVA_COPY='va_copy' -DHAVE_VA_COPY='1' -DHAVE_VA_LIST_AS_ARRAY='1' -DHAVE_THREAD_TLS_KEYWORD='1' -DHAVE_I18N_LC_MESSAGES='1' -DHAVE_LOCALECONV='1' -DMALLOC_H='<malloc.h>' -DHAVE_ALLOCA_H='1' -DHAVE_STRNDUP='1' -DHAVE_POSIX_MEMALIGN='1' -DHAVE_MEMALIGN='1' -DHAVE_MALLOC_USABLE_SIZE='1' -DHAVE_MALLOC_H='1' -DMALLOC_USABLE_SIZE_CONST_PTR='' -DHAVE_VALLOC='1' -DTARGET_XPCOM_ABI='"x86_64-gcc3"' -DNIGHTLY_BUILD='1' -DE10S_TESTING_ONLY='1' -DMOZ_UPDATE_CHANNEL='nightly' -DEARLY_BETA_OR_EARLIER='1' -DMOZ_BUILD_APP='../suite' -DMOZ_X11='1' -DMOZ_WIDGET_GTK='3' -DMOZ_PDF_PRINTING='1' -DMOZ_ENABLE_XREMOTE='1' -DMOZ_INSTRUMENT_EVENT_LOOP='1' -DGLIB_VERSION_MIN_REQUIRED='GLIB_VERSION_2_26' -DGLIB_VERSION_MAX_ALLOWED='GLIB_VERSION_2_32' -DNS_PRINTING='1' -DNS_PRINT_PREVIEW='1' -DMOZ_DISTRIBUTION_ID='"org.mozilla"' -DMOZ_ENABLE_GIO='1' -DMOZ_ENABLE_GCONF='1' -DMOZ_ENABLE_DBUS='1' -DACCESSIBILITY='1' -DMOZ_WEBRTC='1' -DMOZ_WEBRTC_ASSERT_ALWAYS='1' -DMOZ_WEBRTC_SIGNALING='1' -DMOZ_PEERCONNECTION='1' -DMOZ_SCTP='1' -DMOZ_SRTP='1' -DMOZ_SAMPLE_TYPE_FLOAT32='1' -DMOZ_WEBSPEECH='1' -DMOZ_WEBSPEECH_TEST_BACKEND='1' -DMOZ_RAW='1' -DATTRIBUTE_ALIGNED_MAX='64' -DMOZ_WEBM='1' -DMOZ_FFMPEG='1' -DMOZ_FMP4='1' -DMOZ_EME='1' -DMOZ_MEDIA_NAVIGATOR='1' -DMOZ_VPX='1' -DMOZ_VPX_ERROR_CONCEALMENT='1' -DVPX_X86_ASM='1' -DMOZ_VPX_NO_MEM_REPORTING='1' -DMOZ_WAVE='1' -DMOZ_VORBIS='1' -DMOZ_WEBM_ENCODER='1' -DMOZ_GSTREAMER='1' -DGST_API_VERSION='"1.0"' -DMOZ_PERMISSIONS='1' -DENABLE_SYSTEM_EXTENSION_DIRS='1' -DMOZ_WEBGL_CONFORMANT='1' -DMOZ_GAMEPAD='1' -DMOZ_CRASHREPORTER='1' -DMOZ_CRASHREPORTER_ENABLE_PERCENT='100' -DMOZ_LIBAV_FFT='1' -DMOZ_UPDATER='1' -DMOZ_GMP_SANDBOX='1' -DMOZ_SANDBOX='1' -DMOZ_FEEDS='1' -DMOZ_HELP_VIEWER='1' -DMOZ_SAFE_BROWSING='1' -DMOZ_URL_CLASSIFIER='1' -DGL_PROVIDER_GLX='1' -DMOZ_STACKWALKING='1' -DMOZ_LOGGING='1' -DFORCE_PR_LOG='1' -DMOZ_GLUE_IN_PROGRAM='1' -DMOZ_REPLACE_MALLOC='1' -DMOZ_MEMORY='1' -DMOZ_JEMALLOC4='1' -DMOZ_MEMORY_LINUX='1' -DMOZ_SUITE='1' -DMOZ_MORK='1' -DHAVE_MOVEMAIL='1' -DMOZ_SECUREELEMENT='1' -DHAVE___CXA_DEMANGLE='1' -DHAVE__UNWIND_BACKTRACE='1' -DJS_DEFAULT_JITREPORT_GRANULARITY='3' -DMOZ_OMNIJAR='1' -DMOZ_USER_DIR='".mozilla"' -DHAVE_FT_BITMAP_SIZE_Y_PPEM='1' -DHAVE_FT_GLYPHSLOT_EMBOLDEN='1' -DHAVE_FT_LOAD_SFNT_TABLE='1' -DHAVE_FONTCONFIG_FCFREETYPE_H='1' -DMOZ_TREE_PIXMAN='1' -DHAVE_STDINT_H='1' -DHAVE_INTTYPES_H='1' -DMOZ_TREE_CAIRO='1' -DMOZ_ENABLE_SKIA='1' -DUSE_SKIA='1' -DUSE_SKIA_GPU='1' -DMOZ_XUL='1' -DMOZ_PROFILELOCKING='1' -DENABLE_MARIONETTE='1' -DBUILD_CTYPES='1' -DMOZ_PLACES='1' -DMOZ_SOCIAL='1' -DMOZ_SERVICES_COMMON='1' -DMOZ_SERVICES_CRYPTO='1' -DMOZ_SERVICES_SYNC='1' -DMOZ_SERVICES_CLOUDSYNC='1' -DMOZ_BINARY_EXTENSIONS='1' -DMOZ_MACBUNDLE_ID='org.mozilla.seamonkey' -DMOZ_B2G_VERSION='"1.0.0"' -DMOZ_B2G_OS_NAME='""' -DMOZ_APP_UA_NAME='""' -DMOZ_APP_UA_VERSION='"2.41a1"' -DFIREFOX_VERSION='44.0a1' -DMOZILLA_OFFICIAL='1' -DMOZ_TELEMETRY_DISPLAY_REV='2' -DMOZ_TELEMETRY_REPORTING='1' -DMOZ_TELEMETRY_ON_BY_DEFAULT='1' -DMOZ_DATA_REPORTING='1' -DMOZ_DLL_SUFFIX='".so"' -DHAVE_POSIX_FADVISE='1' -DHAVE_POSIX_FALLOCATE='1' -DXP_UNIX='1' -DMOZ_ACCESSIBILITY_ATK='1' -DATK_MAJOR_VERSION='2' -DATK_MINOR_VERSION='8' -DATK_REV_VERSION='0' -DA11Y_LOG='1' -DEXPOSE_INTL_API='1' -DENABLE_INTL_API='1' -DU_STATIC_IMPLEMENTATION='1' -DU_USING_ICU_NAMESPACE='0' -DMOZ_STATIC_JS='1' -DNDEBUG -DTRIMMED '/home/mozilla/jenkins/workspace/seamonkey-central_linux64/mozilla/extensions/irc/locales/generic/install.rdf' -o '../../../dist/xpi-stage/chatzilla-pl/install.rdf'
14:01:40 Traceback (most recent call last):
14:01:40   File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main
14:01:40     "__main__", fname, loader, pkg_name)
14:01:40   File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
14:01:40     exec code in run_globals
14:01:40   File "/home/mozilla/jenkins/workspace/seamonkey-central_linux64/mozilla/python/mozbuild/mozbuild/action/preprocessor.py", line 18, in <module>
14:01:40     main(sys.argv[1:])
14:01:40   File "/home/mozilla/jenkins/workspace/seamonkey-central_linux64/mozilla/python/mozbuild/mozbuild/action/preprocessor.py", line 14, in main
14:01:40     pp.handleCommandLine(args, True)
14:01:40   File "/home/mozilla/jenkins/workspace/seamonkey-central_linux64/mozilla/python/mozbuild/mozbuild/preprocessor.py", line 468, in handleCommandLine
14:01:40     self.processFile(input=input, output=out)
14:01:40   File "/home/mozilla/jenkins/workspace/seamonkey-central_linux64/mozilla/python/mozbuild/mozbuild/preprocessor.py", line 380, in processFile
14:01:40     self.do_include(input, False)
14:01:40   File "/home/mozilla/jenkins/workspace/seamonkey-central_linux64/mozilla/python/mozbuild/mozbuild/preprocessor.py", line 765, in do_include
14:01:40     self.handleLine(l)
14:01:40   File "/home/mozilla/jenkins/workspace/seamonkey-central_linux64/mozilla/python/mozbuild/mozbuild/preprocessor.py", line 543, in handleLine
14:01:40     self.write(aLine)
14:01:40   File "/home/mozilla/jenkins/workspace/seamonkey-central_linux64/mozilla/python/mozbuild/mozbuild/preprocessor.py", line 420, in write
14:01:40     filteredLine = self.applyFilters(aLine)
14:01:40   File "/home/mozilla/jenkins/workspace/seamonkey-central_linux64/mozilla/python/mozbuild/mozbuild/preprocessor.py", line 403, in applyFilters
14:01:40     aLine = f[1](aLine)
14:01:40   File "/home/mozilla/jenkins/workspace/seamonkey-central_linux64/mozilla/python/mozbuild/mozbuild/preprocessor.py", line 722, in filter_substitution
14:01:40     return self.varsubst.sub(repl, aLine)
14:01:40   File "/home/mozilla/jenkins/workspace/seamonkey-central_linux64/mozilla/python/mozbuild/mozbuild/preprocessor.py", line 720, in repl
14:01:40     raise Preprocessor.Error(self, 'UNDEFINED_VAR', varname)
14:01:40 mozbuild.preprocessor.Error: ('/home/mozilla/jenkins/workspace/seamonkey-central_linux64/mozilla/extensions/irc/locales/generic/install.rdf', 12, 'UNDEFINED_VAR', 'MOZ_LANG_TITLE')
14:01:40 make[2]: *** [../../../dist/xpi-stage/chatzilla-pl/install.rdf] Error 1
14:01:40 make[2]: *** Deleting file `../../../dist/xpi-stage/chatzilla-pl/install.rdf'
14:01:40 make[2]: Leaving directory `/home/mozilla/jenkins/workspace/seamonkey-central_linux64/objdir/extensions/irc/locales'
14:01:40 make[1]: *** [libs-pl] Error 2
14:01:40 make[1]: Leaving directory `/home/mozilla/jenkins/workspace/seamonkey-central_linux64/objdir/extensions/irc/locales'
14:01:40 make: *** [libs-pl] Error 2
14:01:40 make: Leaving directory `/home/mozilla/jenkins/workspace/seamonkey-central_linux64/objdir/suite/locales'
This did work at least until Sept., 26th. It must have been broken sometime between that date and Oct., 9th, when I first did notice this error.


At first, I though I need to add 'MOZ_LANG_TITLE' to the defines.inc file in my ChatZilla localization - but that did not change anything...
Depends on: 1209875
See Also: → 1210791
Duplicate of this bug: 1209729
Fixed downloading locales & putting in /../src/obj-sm-release/dist/bin/dictionaries
(In reply to fabrixx2 from comment #3)
> Fixed downloading locales & putting in
> /../src/obj-sm-release/dist/bin/dictionaries

download charzilla langfile &put in
/src/obj-sm-release/dist/bin/distribution/extensions
This is actually probably a dupe of bug 1210791
Also, if you can try the patch I have attached there and tell me if it works, that would be very much appreciated.
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #6)
> Also, if you can try the patch I have attached there and tell me if it
> works, that would be very much appreciated.

The patch posted there works :)

(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #5)
> This is actually probably a dupe of bug 1210791

Yeah, it is...
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1210791
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.