Closed Bug 1213670 Opened 4 years ago Closed 4 years ago

Remove dom/imptests/ that aren't likely to be platform-specific

Categories

(Testing :: web-platform-tests, defect)

defect
Not set

Tracking

(firefox48 fixed)

RESOLVED FIXED
mozilla48
Tracking Status
firefox48 --- fixed

People

(Reporter: ayg, Assigned: ayg)

Details

Attachments

(1 file)

We apparently don't want to get rid of all of dom/imptests/ yet even though it's superseded by testing/web-platform-tests/ because wpt doesn't yet run on all platforms.  I'd like to at least get rid of the tests that are very unlikely to have platform-specific behavior.
Attached patch PatchSplinter Review
My selection is a bit arbitrary and not entirely uncorrelated with how much I expect to be poking at the tests in question over the next few days.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=8dfb152f3d0e
Attachment #8672405 - Flags: review?(james)
Comment on attachment 8672405 [details] [diff] [review]
Patch

Review of attachment 8672405 [details] [diff] [review]:
-----------------------------------------------------------------

Can you post a summary of the directories you selected for [partial] deletion, just to make reviewing this a bit easier?
Attachment #8672405 - Flags: feedback?(bzbarsky)
Attachment #8672405 - Flags: feedback?(Ms2ger)
All of editing, and all of HTML except for microdata (should be removed in bug 869788), typedarrays, and webgl.  That means in HTML I'm removing: dom, domxpath, html, and js.

Previous try run was build-only, which is useless.  New try run: https://treeherder.mozilla.org/#/jobs?repo=try&revision=8656678b91a3
Comment on attachment 8672405 [details] [diff] [review]
Patch

How do these tests get in the way?  What's the timeframe on removing these wholesale, if we have one?

It seems like annoying extra work to do this in bits and pieces....
Attachment #8672405 - Flags: feedback?(bzbarsky)
They at least somewhat get in the way by requiring extra runtime when we are looking to at ways to improve efficiency. I agree that it's not very high impact though.

I think the timeframe for removing them wholesale depends on whether a) they run on mobile platforms (I assume they do) and b) whether wpt needs to also run on mobile to be considered an acceptable replacement. If that's the case the timeframe is "no one is working on that right now" i.e. unknown.

I don't know if disabling all of imptests on desktop only would be acceptable.
They get in my way because when I'm fixing bugs I have to fix expected passes twice.  :)

Some of these tests are already disabled on mobile because they're too slow, such as some of the editor and range tests.  It seems to me a lot of tests are disabled on mobile for various reasons, so I'm not sure that should block getting rid of these wholesale.  Who's the one to decide that?  Maybe some of the mobile people?

If you have specific clearly-stated tasks to do to get wpt running on mobile, I can possibly take a look, but I'll probably need my hand held a bit (because I know nothing about test infra).
If the issue is just mobile vs not, then I think most of these tests can be removed, yeah.
Poke?
Flags: needinfo?(james)
Comment on attachment 8672405 [details] [diff] [review]
Patch

Review of attachment 8672405 [details] [diff] [review]:
-----------------------------------------------------------------

Based on feedback from bz and Ms2ger. Note the patch needs some rebasing to apply to current tip.
Attachment #8672405 - Flags: review?(james) → review+
Flags: needinfo?(james)
https://hg.mozilla.org/mozilla-central/rev/349594185fac
https://hg.mozilla.org/mozilla-central/rev/5d450730e3e2
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
Attachment #8672405 - Flags: feedback?(Ms2ger)
You need to log in before you can comment on or make changes to this bug.