Status

()

Core
HTML: Parser
RESOLVED DUPLICATE of bug 100930
17 years ago
16 years ago

People

(Reporter: Tim Coote, Assigned: harishd)

Tracking

({compat, testcase})

Trunk
x86
Windows 2000
compat, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
this could be down to bad html, but the browser ought to be more forgiving. At
the url above, look for sections "Certification Rules", and "Enforcement Rules".
First bullets are misaligned (just above) the text that they refer to.  I think
that this is the relevant html:
" <p><font face="Arial" size="2">In the formulation in Amoroso [1] the nine
rules for CW
    model are:</font></p>
<b><p><font face="Arial" size="2">Certification Rules</font></b><ul>
<b><u>
<li></u></b><font face="Arial" size="2"><strong>C1 (IVP Certification)</strong>
- The system
        will have an IVP for validating the integrity of any CDI.</font></li>
</ul>
<ul>
<li><font face="Arial" size="2"><strong>C2 (Validity)</strong> - The application
of a TP to
        any CDI must maintain the integrity of that CDI. CDIs must be certified
to ensure that
        they result in a valid CDI</font></li>
</ul>
<ul>
<li><font face="Arial" size="2"><strong>C3</strong> - A CDI can only be changed
by a TP. TPs
        must be certified to ensure they implement the principles of separation
of duties &amp;
least privilege</font></li>
</ul>
<ul>
<li><font face="Arial" size="2"><strong>C4 (Journal Certification)</strong> -
TPs must be
        certified to ensure that their actions are logged</font></li>
</ul>
<ul>
<li><font face="Arial" size="2"><strong>C5</strong> - TPs which act on UDIs must be
        certified to ensure that they result in a valid CDI</font></li>
</ul>

"

It looks to me like the code for the first bullet is slightly different, with
possibly poor embedding of tags and possible the Mozilla is correct, so this may
be something that should be handled by whatever education process there is for
helping folk not just test their html with IE :-)

Comment 1

17 years ago
Confirming and over to Parser. The problem is the wrong order of <u> and <li>:

    <ul>
      <u><li></u>C1 (IVP Certification) - The system
        will have an IVP for validating the integrity of any CDI.</li>
Assignee: attinasi → harishd
Status: UNCONFIRMED → NEW
Component: Layout → Parser
Ever confirmed: true
QA Contact: petersen → moied

Comment 2

17 years ago
Created attachment 66097 [details]
Simplified testcase

Comment 3

17 years ago
So I don't know if this is
  a) Invalid because of the bad HTML (my vote for this one)
  b) Evangelism because of the bad HTML
  c) Parser because Mozilla shouls handle this gracefully.

Comment 4

17 years ago
It seems more to be a parser bug, because there is no reason the <u> change the
way <li> work.

/jc
Well those are 3 possible options but how about a fourth:

  d) dupe

Bug 100930 shows the same behavior because of similar bad HTML.  A tag is opened
before the <li> and then closed within the <li> so it causes weird behavior. 
However the testcases differ slightly, so it is possible that they are not the
same fix (though I suspect that they are).  I'll leave this open for now.  harish?
Keywords: compat, testcase
(Assignee)

Comment 6

16 years ago
Different scenario but same bug. Marking dupe of bug 100930.

*** This bug has been marked as a duplicate of 100930 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.