mozilla starter script has problems with locale

VERIFIED FIXED

Status

SeaMonkey
Build Config
--
critical
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: Harald Böhme, Assigned: Frank Belew)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; de-AT; rv:0.9.7) Gecko/20020104
BuildID:    20002010417

In the "mozilla" starter shell script the command type is used to find the
location of mozilla-bin. Output of that command is processed with sed and 
it asumes the that LC_MESSAGES is empty or "C". With other values type will
return other mesages.

Solution:

MOZ_PROGRAM=`type mozilla-bin | sed -e 's/^mozilla-bin is //'`

has to be changed to
MOZ_PROGRAM=`LC_MESSAGES=C type mozilla-bin | sed -e 's/^mozilla-bin is //'`

Regards,
		Harald

Reproducible: Always
Steps to Reproduce:
1.set LC_MESSAGES to "de" or some not engl. languages
2. call mozilla

Actual Results:  you got the following error message:

Mozilla has not been installed correctly.

Please either reinstall the application or ask your
system administrator to run
mozilla-bin ist /opt/gnome//lib/mozilla/rebuild-databases.sh


Expected Results:  starting the mozilla-bin
dupe of bug 121274 ?
(Reporter)

Comment 2

17 years ago
No it isn't. This has to be fixed in the shell-script which is used for
all Unix systems to start the binary. The other problem is in C/C++.

Comment 3

17 years ago
cls: what do you think?
Assignee: asa → seawood
Component: Browser-General → Build Config
Keywords: patch
QA Contact: doronr → granrose
I think that this should be filed against whomever provided that Mozilla
distribution.  We use type in our run-mozilla.sh script to check for debuggers
and to find md5sum but I don't see where we set MOZ_PROGRAM using type.  The
stock mozilla script doesn't use type at all.
(Reporter)

Comment 5

17 years ago
I use a mozill from Ximian for Solaris8. But I asume that the script
is from mozilla directly. So if you use type for finding mozilla-bin
be prepared taht it will come with non engl. messages. Otherwise you
should set LC_MESSAGES for the command to "C".

Regrads,
           Harald
Since you said the magic word (ximiam), this is going over to frb.
Assignee: seawood → frb
(Reporter)

Comment 7

17 years ago
Hmmm

It dosen't look like a Ximian special so I reporte it here.

Comment 8

16 years ago
Does this bug still exist in recent mozilla builds (from Ximiam)?

Harald, could you try a more recent build and close this bug if it works now?
(Assignee)

Comment 9

16 years ago
Oh, I fixed this earlier by leeching blizzard's script and fixing it up for
multiple prefixes. There shouldn't be any locale problems anymore. Marking as fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

16 years ago
Ok, finaly we have a new mozilla version out from Ximian for solaris.
This version dosen't have that problem anymore.

Thanks
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.