Closed Bug 12141 Opened 23 years ago Closed 23 years ago

Shift_JIS to Unicode conversion failure

Categories

(Core :: Internationalization, defect, P1)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: momoi, Assigned: ftang)

References

()

Details

(Whiteboard: have fix in local disk. Need approved to check in to M9 branch.)

** Observed with 8/16/99 Win32 M9 candidate bug **

We are failing in Shift_JIS to Unicode conversion where the Shift_JIS
character contains 2nd byte value of C0, C1, and C2.

This affects Japanese display in Browser and Mail massively and
we cannot ship M9 without fixing this.
Priority: P3 → P1
Target Milestone: M9
*** Bug 12144 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
Whiteboard: have fix in local disk. Need approved to check in to M9 branch.
Z:\mozilla\intl\uconv\ucvja>cvs diff -c nsJapaneseToUnicode.cpp
Index: nsJapaneseToUnicode.cpp
===================================================================
RCS file: /m/pub/mozilla/intl/uconv/ucvja/nsJapaneseToUnicode.cpp,v
retrieving revision 1.3
diff -c -r1.3 nsJapaneseToUnicode.cpp
*** nsJapaneseToUnicode.cpp     1999/08/09 21:06:55     1.3
--- nsJapaneseToUnicode.cpp     1999/08/19 19:05:09
***************
*** 108,114 ****
        103,  104,  105,  106,  107,  108,  109,  110,  /* 0xa8 */
        111,  112,  113,  114,  115,  116,  117,  118,  /* 0xb0 */
        119,  120,  121,  122,  123,  124,  125,  126,  /* 0xb8 */
!       137,  138,  139,  130,  131,  132,  133,  134,  /* 0xc0 */
        135,  136,  137,  138,  139,  140,  141,  142,  /* 0xc8 */
        143,  144,  145,  146,  147,  148,  149,  150,  /* 0xd0 */
        151,  152,  153,  154,  155,  156,  157,  158,  /* 0xd8 */
--- 108,114 ----
        103,  104,  105,  106,  107,  108,  109,  110,  /* 0xa8 */
        111,  112,  113,  114,  115,  116,  117,  118,  /* 0xb0 */
        119,  120,  121,  122,  123,  124,  125,  126,  /* 0xb8 */
!       127,  128,  129,  130,  131,  132,  133,  134,  /* 0xc0 */
        135,  136,  137,  138,  139,  140,  141,  142,  /* 0xc8 */
        143,  144,  145,  146,  147,  148,  149,  150,  /* 0xd0 */
        151,  152,  153,  154,  155,  156,  157,  158,  /* 0xd8 */
*** Bug 12144 has been marked as a duplicate of this bug. ***
I change the URL so it is easy to verify.
Status: ASSIGNED → RESOLVED
Closed: 23 years ago
Resolution: --- → FIXED
fixed and check in.
Status: RESOLVED → VERIFIED
I verified this in 8-20 Win32 and Mac M9 builds.
You need to log in before you can comment on or make changes to this bug.