[Simulator] TV Simulator was crashed when switched channels.

RESOLVED INVALID

Status

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: mantaroh, Assigned: mantaroh)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

3 years ago
The simulated TV Manager API was crashed when change channels a few times.

Reproduce Step:
 1. get TVSource via TV Manager API[1]
 2. call TVSource.setCurrentChannel API few times.

Actually Result:
 crashed b2g

Expected Result:
 We can change the channel not crashed.

[1] http://seanyhlin.github.io/TV-Manager-API/

Updated

3 years ago
Blocks: 1201451
(Assignee)

Updated

3 years ago
Blocks: 1214513

Updated

3 years ago
Depends on: 1214520
(Assignee)

Comment 1

3 years ago
In windows and OSX,
b2g-bin crashed using current dummy video files.
According to WinDgb the cause is omemory corruption.

However it will not crash change the dummy video to other file.

I think that this cause similar to bug 1214506.

I'll continue to investigate crash reason.

Comment 2

3 years ago
(In reply to Mantaroh Yoshinaga[:mantaroh] from comment #1)
> In windows and OSX,
> b2g-bin crashed using current dummy video files.
> According to WinDgb the cause is omemory corruption. 

I cannot reproduce it on my Linux PC.  Does the crash only happen on these two platforms?

Comment 3

3 years ago
Hi Daosheng, could you help to get GDB log for this crash issue on Mac?  Thanks!
Flags: needinfo?(dmu)
Hi, I pull the latest version of Gecko and Gaia, and I can't reproduce this problem on Mac and Windows.
Flags: needinfo?(dmu)

Comment 5

3 years ago
I can't reproduce this issue now. My build is latest Gecko/Gaia and patch on bug 1206621. Thanks for your help!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.