Closed Bug 1214200 Opened 4 years ago Closed 4 years ago

crash in mozilla::detail::AtomicBaseIncDec<T>::operator--()

Categories

(Core :: Networking, defect, critical)

Unspecified
Linux
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla44
Tracking Status
firefox43 --- unaffected
firefox44 --- fixed

People

(Reporter: bbouvier, Assigned: bagder)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-3f2442e3-c997-46b5-bc98-067c82151013.
=============================================================

Happening several times, often when I open a new tab with an URL. Fwiw, I do have a proxy enabled on my Firefox. Please let me know if I can prodive further information.

Seeing that the patch that introduced the line was in bug 1121800, so cc-ing reviewer and author.
Crash Signature: [@ mozilla::detail::AtomicBaseIncDec<T>::operator--()] → [@ mozilla::detail::AtomicBaseIncDec<T>::operator--()] [@ mozilla::detail::AtomicBaseIncDec<T>::operator--]
I'm getting 3 or 4 crashes an hour with this signature. If it's really related to all proxies, this might mean that all people using a proxy will be affected. Can somebody look at this, please? It makes Nightly unusable.
Assignee: nobody → daniel
When all the proxies are disabled, the loop has already done NS_RELEASE() on the pointer 'head' points to (at line 1998, when the 'reject' pointer points to the entry). By removing this single NS_RELEASE() we avoid a double NS_RELEASE().
Attachment #8674475 - Flags: review?(mcmanus)
Attachment #8674475 - Flags: review?(mcmanus) → review+
Keywords: checkin-needed
Duplicate of this bug: 1215563
Crash Signature: [@ mozilla::detail::AtomicBaseIncDec<T>::operator--()] [@ mozilla::detail::AtomicBaseIncDec<T>::operator--] → [@ mozilla::detail::AtomicBaseIncDec<T>::operator--()] [@ mozilla::detail::AtomicBaseIncDec<T>::operator--] [@ nsProxyInfo::Release()]
Duplicate of this bug: 1215784
https://hg.mozilla.org/mozilla-central/rev/a62a3c113e40
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Crash Signature: [@ mozilla::detail::AtomicBaseIncDec<T>::operator--()] [@ mozilla::detail::AtomicBaseIncDec<T>::operator--] [@ nsProxyInfo::Release()] → [@ mozilla::detail::AtomicBaseIncDec<T>::operator--()] [@ mozilla::detail::AtomicBaseIncDec<T>::operator--] [@ nsProxyInfo::Release()] [@ nsProxyInfo::Release]
Duplicate of this bug: 1216871
Depends on: 1207798
You need to log in before you can comment on or make changes to this bug.