Closed Bug 1214280 Opened 6 years ago Closed 6 years ago

Users are unable to import contacts from memory card in FTU/FTE

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: AdamA, Assigned: ferjm)

References

Details

(Keywords: regression, smoketest, Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(4 files)

Attached file logcat
Description:
If the user is going through the first time use and tries to import contacts from the memory card. Importing contacts from the memory card in the contacts app works correctly.

Repro Steps:
1) Update a Aries to 20151013110851
2) Proceed through the FTU to the import contacts screen
3) Choose to import contacts from the memory card
4) Observe screen

Actual:
Contacts never import from the memory card

Expected:
It is expected that contaccts import from the memory card

Environmental Variables:
Device: Aries 2.5 [Full Flash]
Build ID: 20151013110851
Gaia: d400cda6bf0f8b30dcf7d7d71bfa61f29a3f1588
Gecko: 607a236c229994df99766c005f9ec729532d7747
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Repro frequency: 10/10
Link to failed test case: https://moztrap.mozilla.org/manage/case/6119/
See attached: screenshot, logcat
QA Whiteboard: [QAnalyst-Triage?]
Keywords: smoketest
Whiteboard: [Spark]
Whiteboard: [Spark] → [2.5-Daily-Testing][Spark]
This issue DOES occur on Flame 2.5.

Environmental Variables:
Device: Flame 2.5 [Full Flash]
BuildID: 20151013030230
Gaia: d400cda6bf0f8b30dcf7d7d71bfa61f29a3f1588
Gecko: 607a236c229994df99766c005f9ec729532d7747
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Result:
Contacts never import from the memory card
------------------------------------
This issue DOES NOT occur on Flame 2.2.

Environmental Variables:
Device: Flame 2.2 [Full Flash]
BuildID: 20151006032504
Gaia: 5dd95cfb9f1d6501ce0e34414596ef3dd9c2f583
Gecko: fc588eb28eab
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Result:
The contacts import in the FTU.
Flags: needinfo?(ktucker)
Keywords: regression
[Blocking Requested - why for this release]: Functional regression

Sounds like a blocker. Can we get a window on when this might have regressed?
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: qaurgent
QA Contact: jthomas
B2g Inbound Regression Window

Last Working
Device: Flame 2.5
BuildID: 20151001110326
Gaia: b4faf783aa6ea63eb2393ea15d403bb964cb4085
Gecko: ed833afe16580afa00d165b32aeacc83da3587e8
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

First Broken
Environmental Variables:
Device: Flame 2.5
BuildID: 20151001112526
Gaia: 4bf2db336772423ea65bab48c83672de20db6de2
Gecko: eb63a639d8526c9094665ef703513041989ab1ef
Version: 44.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Last Working gaia / First Broken gecko - This issue 
Gaia: b4faf783aa6ea63eb2393ea15d403bb964cb4085
Gecko: eb63a639d8526c9094665ef703513041989ab1ef

Last Working gecko / First Broken gaia - This issue 
Gecko: ed833afe16580afa00d165b32aeacc83da3587e8
Gaia: 4bf2db336772423ea65bab48c83672de20db6de2

B2g Inbound Pushlog: 
https://github.com/mozilla-b2g/gaia/compare/b4faf783aa6ea63eb2393ea15d403bb964cb4085...4bf2db336772423ea65bab48c83672de20db6de2

This issue is caused by changes made in Bug 1115329
Blocks: 1115329
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Fernando this issue seems to have been caused by bug 1115329.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(ferjmoreno)
Component: Gaia::First Time Experience → Gaia::Contacts
Assignee: nobody → ferjmoreno
Flags: needinfo?(ferjmoreno)
blocking-b2g: 2.5? → 2.5+
Component: Gaia::Contacts → Gaia::First Time Experience
Status: NEW → ASSIGNED
Attachment #8674162 - Flags: review?(francisco)
Comment on attachment 8674162 [details] [review]
[gaia] ferjm:bug1214280.sdcard.ftu > mozilla-b2g:master

LGTM, left a tiny comment on gh, but definitely this can be merged.
Attachment #8674162 - Flags: review?(francisco) → review+
https://github.com/mozilla-b2g/gaia/commit/0b170e87c37c2e47bafb50a69117461c15e0e9e1
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aries KK 2.5 by the STR in comment 0.

Actual results: Contacts can be imported from the memory card when there are contacts in memory card.

See attachment: Aries_KK_v2.5.3gp
Reproduce rate: 0/10

Device: Aries KK 2.5 (Pass)
Build ID               20151018193053
Gaia Revision          f75a7e01912cee313fed92ff2089586f507b2ba5
Gaia Date              2015-10-16 13:00:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d1a89632277fbaaf470c90a35573776048988f2d
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151018.185047
Firmware Date          Sun Oct 18 18:50:55 UTC 2015
Bootloader             s1

Device: Flame KK 2.5 (Pass)
Build ID               20151018150205
Gaia Revision          f75a7e01912cee313fed92ff2089586f507b2ba5
Gaia Date              2015-10-16 13:00:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d1a89632277fbaaf470c90a35573776048988f2d
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151018.182341
Firmware Date          Sun Oct 18 18:23:52 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.