Closed Bug 1214303 Opened 4 years ago Closed 4 years ago

Playing attached audio file from Messenger with no music in library will give a "Load songs on to memory card" message

Categories

(Firefox OS Graveyard :: Gaia::Music, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
FxOS-S10 (30Oct)
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: jthomas, Assigned: hub)

References

()

Details

(Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(3 files)

Description:
If the user has no music in library and attempts to play a sent (or received) audio attachment from an MMS in Messenger they will receive the following message "Add songs to get started Load songs on to the memory card"


Repro Steps:
1) Update a Aries to 20151013111622
2) Select Settings > Sound > Manage Tones
3) Select the "..." of any song.
4) Select Share ringtone > Messages
5) Send attachment to a contact.
6) Press Play on attachment.

Actual:
After attempting to play audio attachment the user receives the following message "Add songs to get started - Load songs on to the memory card"

Expected:
It is expected that the user will be able to play the attached sound from the messenger app even if they do not have any tracks already in library.

Environmental Variables:
Device: Aries 2.5 Kk
BuildID: 20151013111622
Gaia: d400cda6bf0f8b30dcf7d7d71bfa61f29a3f1588
Gecko: afa71e48a9f1ec9f96c5bc107560659d3b15c96e
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Repro frequency: 4/4
See attached: Logcat & Video
Note: This issue will reproduce with Music, but NOT with Music OGA. This is a Music NGA bug making this NOT a regression.

This issue DOES occur on the Flame 2.5
Result: User receives the following message "Add songs to get started - Load songs on to the memory card"

Environmental Variables:
Device: Flame 2.5 Kk Fullflash (512mb)
BuildID: 20151013030230
Gaia: d400cda6bf0f8b30dcf7d7d71bfa61f29a3f1588
Gecko: 607a236c229994df99766c005f9ec729532d7747
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

-----------------------------------------------------------------

This issue does NOT occur on the Flame 2.2.
Result: User is able to play the attached audio file successfully.
Environmental Variables:
Device: Flame 2.2 Kk Fullflash (319mb)
BuildID: 20151006032504
Gaia: 5dd95cfb9f1d6501ce0e34414596ef3dd9c2f583
Gecko: fc588eb28eab
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Whiteboard: [2.5-Daily-Testing][Spark]
Similar to Bug 1214019
Flags: needinfo?(jdarcangelo)
Summary: Playing attached audio file from Messenger with no music in library will give a "Load songs on to memory card message" → Playing attached audio file from Messenger with no music in library will give a "Load songs on to memory card" message
No-Jun I'm not sure if this should be nominated as a blocker or not.  Can I get your opinion?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(npark)
[Blocking Requested - why for this release]:

Since it's a regression (it doesn't happen on OGA) and the use case is pretty straightforwards, I believe this is a blocker.
blocking-b2g: --- → 2.5?
Flags: needinfo?(npark)
blocking-b2g: 2.5? → 2.5+
Priority: -- → P2
Hub,

Please take this one for investigation. Justin has a few P1s that needs to be wrapped up first. 

THanks
Hema
Assignee: nobody → hub
If I get lucky reproducing without MMS. I don't have a SIM card in the dev phone.
We should even be able to test this with the integration tests.... 

(I can reproduce)

Missing and IMPORTANT STR left out: make sure you have no songs in the library.
I have https://github.com/hfiguiere/gaia/tree/bug1214303-play-activity to implement tests for this. And they currently fail as this bug shows.
Comment on attachment 8674957 [details] [review]
[gaia] hfiguiere:bug1214303-play-activity > mozilla-b2g:master

I took the route of removing what we don't need.
Attachment #8674957 - Flags: review?(jdarcangelo)
Status: NEW → ASSIGNED
Comment on attachment 8674957 [details] [review]
[gaia] hfiguiere:bug1214303-play-activity > mozilla-b2g:master

The approach you took was the same as my initial thought too, however, we can kill 2 bugs at once (Bug 1193491) if we simply "don't show 'add songs' overlay if music is playing".
Flags: needinfo?(jdarcangelo)
Attachment #8674957 - Flags: review?(jdarcangelo) → review-
Except that it seems that we are not playing. But that looks like bug 1214019.
I probably fixed this in bug 1208987, but I'm all for removing the overlays from the open activity. They don't need to be there.
Indeed the test pass with your patch.
In that case, let's remove this from the blocker list, since things are functional now (but the code could still be improved).
blocking-b2g: 2.5+ → ---
Comment on attachment 8674957 [details] [review]
[gaia] hfiguiere:bug1214303-play-activity > mozilla-b2g:master

Reviewing again as the bug is actually fixed, but 1. tests 2. jim suggested we remove the overlays which falls under "Your aren't gonna need it"

Gaia-try is super green.
Attachment #8674957 - Flags: review- → review?(jdarcangelo)
Comment on attachment 8674957 [details] [review]
[gaia] hfiguiere:bug1214303-play-activity > mozilla-b2g:master

Cool. Let's ship it!
Attachment #8674957 - Flags: review?(jdarcangelo) → review+
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S10 (30Oct)
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aries KK 2.5 by the STR in comment 0.

Actual results: User can play the attached sound from the messages app when there is no music in library.
See attachment: verified_Aries KK_v2.5.3gp
Reproduce rate: 0/10

Device: Aries KK v2.5 (Pass)
Build ID               20151023005002
Gaia Revision          29ce8ec8606e59f582375234440812b046346513
Gaia Date              2015-10-22 05:31:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1f03a14106e59280761ac53904340f389674337f
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151023.001128
Firmware Date          Fri Oct 23 00:11:35 UTC 2015
Bootloader             s1

Device: Flame KK v2.5 (Pass)
Build ID               20151022150207
Gaia Revision          29ce8ec8606e59f582375234440812b046346513
Gaia Date              2015-10-22 05:31:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/76bd0c01d72e64ca4f261ffdb2652a91f961e930
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151022.185000
Firmware Date          Thu Oct 22 18:50:13 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+], [MGSEI-Triage+]
Duplicate of this bug: 1117678
You need to log in before you can comment on or make changes to this bug.