Sharing a link and sharing a music song it takes an user to a web browser.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED WONTFIX
3 years ago
3 months ago

People

(Reporter: VladimirBelonenko, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8673320 [details]
logcat_20151013_1349.txt

Description:
When user shares a web page with messages, while Attaching music song to messaging. He select a song and inside the song playlist shares a message, it takes him directly to Google page.

Repro Steps:
1) Update a Aries to 20151013110851
2) Select web browser and go to google.com
3) Select options and click share with messages.
4) Attach music and select song( File should not exceed the 295 kb size)
5) select share inside the music app song and click messages.
6) Observe that it takes you to Google web page.

Actual:
After selecting a song and sharing it with messages, it takes user directly to google web page.

Expected:
When user shares a song with a messages app, it should take him to messaging app.

Notes: When sharing a song,  file should not exceed 295 kb size

Environmental Variables:
Device: Aries Master 2.5 kk full flash (319 mb)
Build ID: 20151013110851
Gaia: d400cda6bf0f8b30dcf7d7d71bfa61f29a3f1588
Gecko: 607a236c229994df99766c005f9ec729532d7747
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Repro frequency: 3/3 
See attached: video clip and logcat
(Reporter)

Comment 1

3 years ago
Correction to Comment 0. The Aries is not on 319mb of memory.

This issue does occurs on 2.5 flame

Result: When user shares a song with a messages app, it took the user back to the browser.

Environmental Variables:
Device: Flame Master 2.5 kk full flash (512 mb)
Build ID: 20151013030230
Gaia: d400cda6bf0f8b30dcf7d7d71bfa61f29a3f1588
Gecko: 607a236c229994df99766c005f9ec729532d7747
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (Master)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Does not happen on flame 2.2, does not support share icon inside the music app.
QA Whiteboard: [QAnalyst-Triage+]
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Summary: Attaching music song to messaging and trying to share with messager app, it takes you to web page where you start. → Sharing a link and sharing a music song it takes an user to a web browser.
Is this a regression?
Keywords: qawanted
(In reply to Gregor Wagner [:gwagner] from comment #2)
> Is this a regression?

We have no way of finding out because as comment 1 stated, step 5 cannot be executed via Music OGA because the feature is not there.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Flags: needinfo?(ktucker)

Comment 4

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.