Closed Bug 121442 Opened 18 years ago Closed 17 years ago

Cannot select hyperlinked text

Categories

(Core :: Selection, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 135410
Tracking Status
firefox43 --- fixed

People

(Reporter: davidmaxwaterman+bugzilla-daemon, Assigned: mjudge)

References

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; MSIE5.5; Windows 98;)
BuildID:    

Text on a web page which is hyperlinked (using <a href="...">text</a>) isn't
selectable using the mouse. One used to be able to select the text using the
middle mouse button.

Reproducible: Always
Steps to Reproduce:
1.goto <http://www.mozilla.org/>
2.place mouse pointer over 'The Mozilla Organization'
  the pointer turns from an arrow to a hand
3.click and hold the middle mouse button - drag the pointer over the text. The
text does not highlight indicating it isn't being selected/copied into the copy
buffer

Actual Results:  step 3 doesn't highlight the text and doesn't copy any text
into the window system's copy buffer

Expected Results:  step 3 should highlight the text and it should be copied into
the window system's copy buffer
-->selection
cc akkana in case she knows of middle-mouse-button specific issues related to this
Assignee: trudelle → mjudge
Component: XP Apps → Selection
QA Contact: sairuh → tpreston
No idea -- I'd never heard of selecting this way.  When did this last work?  I
thought the only way to drag-select text inside an a tag was to start dragging
(with the left button) from the character immediately before or after it (of
course, you can always right-click on the link and do "copy link address").
middle-button drag seems entirely undiscoverable, and would no doubt lead to
inadvertant paste on Linux.
I'm not sure when it stopped working. I know none of the recent mozilla versions
have this capability. I can only run netscape 4.79 right now, and I know that
has this capability. I forget if the netscape 6.X series have it...

I see that the left mouse button seems to behave the same way, so that is good
enough as far as I am concerned.

I don't think the 'copy link address' works, since the link address can be
completely different to the text it links. An option 'copy link text' on the
same menu might be an ideal solution, since even with the middle button drag
method of selecting, it was kind of hit-and-miss. Any chance of implementing that?

I don't know what 'undiscoverable means', but I've been using this middle-mouse
selecting method for years, and it rarely results in an inadvertant paste on
either Linux or IRIX (the only platforms I use).

I think adding a 'copy link text' would work well. Or you can just ignore this
and I'll take the hint to use the left button instead.

Max.
I've just tried netscape 6.2, which is, of course, based on mozilla, and, no, it
doesn't work either. So, the behaviour I describe is from netscape 4.XX.

I'm happy with the left mouse button, but would he happier with a menu option.
It has to be a low priority though.

Your call.

Max.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+) Gecko/20020123
If I left-click drag, starting in a hyperlink, Mozilla will select the link
text.  However, Edit->Copy of that text does not work, and neither does
middle-click paste.

Perhaps enabling Edit->Copy or middle-click paste of that already-selected text
would be a better fix for this than adding Middle-click-drag select as a new
feature.
I notice that left-dragging on a link will produce a little 'piece of paper' by
the mouse pointer. Dropping that on anything in mozilla will paste it, but if
you drop it on anything else (eg an xterm) it won't. I think that should work
for an xterm too.

I'm not sure about just copying the text to clipboard, since you actually have
to drag over the link, and that is doing a different operation.

I still think left-drag as it works now is fine, and a menu option to copy the
link text would be perfect.

Max.
For me, the first drag 'n drop copies the link, but any drag 'n drops after that
copies the text.
> ------- Additional Comments From ajschult@eos.ncsu.edu  2002-01-26 12:29 -------
> For me, the first drag 'n drop copies the link, but any drag 'n drops after that
> copies the text.

Yeah. Me too (on IRIX). That isn't intuitive and can't be intended, surely?

Max.
duplicate of bug 118785 ?
Whiteboard: DUPEME
most of the discussion in bug 118785 (and the reason for its INVALIDity) was 
trying to select a link in a table selecting the whole page before the link. 
The issues here are different.

Note that the behavior in comment 6 is slightly better now.  If you drag a link
(which highlights the link) and then Edit->Copy, Edit->Paste will paste the text
properly.  Middle-click paste in that case still does not work.  The rest of the
behavior remains.
So do we still have a bug here? Can we create a new bug that describes an
actionable problem in Mozilla? 
Whiteboard: DUPEME → DUPEME pending
yes, it's still a problem, even though there's a w/a (to start the selection
from off the hyperlink), since it doesn't allow you to select part of the text
not on the end of the linked text.

This isn't platform specific (Mac OS X also, at least), so changing platform and OS.

Max.
OS: Linux → All
Hardware: PC → All
QA Contact: tpreston → pmac
bug 80026 sounds like the same as this, but was resolved as dup of bug 79793, a
D&D bug. What i see is that instead of a selection occuring, a drag immediately
triggers when i try to perform a partial selection of a link. Perhaps the d&d
code should be as agressive? Then again.. Blake swore to get the head of whoever
caused  bug 79793... 
possible dupes fixed
can anybody reproduce this ?
Yes, it's trivial to reproduce. Just try to select part of some text which is hyperlinked.

Max.
Confirming that in Netscape 4.79 (Linux) you can select with the middle mouse
button. It does not Work in Mozilla (trunk). But, as Akkana said, this is a
feature almost nobody ever heard of. So suggesting WONTFIX.

pi
I think something needs to be done, even if the original behaviour isn't restored.

The should at least be an option on the right mouse menu to 'copy link text',
right under 'copy link location'. This wouldn't allow you to select part of the
links text, but the whole of the links text can be copied and editted in the
destination application.

I don't think WONTFIX is an option - there needs to be some way of selecting
text, even if it isn't the original behaviour. Selecting with the left mouse,
starting from off the link, sort of works, but is messy.

Max.
You already can copy all of the text. Also part, if you start at the "border" of
the displayed text.

pi
Er, I did say that, if you read what I said, but's it messy and non-intuitive.

Please consider adding a menu option 'copy link text' right under 'copy link
location'.

Thanks.

Max.
Max, we have differnt issues.

Your original request was about marking parts of the link text. Bug 135410 asked
about this and was marked WFM.

Now you want to copy the complete link text. You can do this by holding shift
while the mouse pointer is over the link and just moving the mouse a bit. Bug
133661 asks for that context menu entry. If you just want this, please dupe on
this one which clearly states this.

pi
Nobody complaint to my last comment, so be it.

pi

*** This bug has been marked as a duplicate of 133661 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME pending
> Max, we have differnt issues.

Maybe. Sorry for the delay, but I was (and still am) on sabbatical.

> Your original request was about marking parts of the link text. Bug 135410 
> asked about this and was marked WFM.

Well, not specifically. It was about selecting hyperlinked text, not just part
of, but including part of the link text.

> Now you want to copy the complete link text.

Of course I want to select the complete link text. I want to select any or all
of hyperlinked text.

> You can do this by holding shift
> while the mouse pointer is over the link and just moving the mouse a bit.

Well, call me stupid, but that doesn't work for me. When I do that, I get a menu
which has 'copy link location...' and 'copy', but the first copies the URL, and
the second doesn't seem to do anything.

> Bug
> 133661 asks for that context menu entry. If you just want this, please dupe on
> this one which clearly states this.

I want to be able to copy any or all parts of hyperlinked text. All I can do is
select parts or all of the text from either end of the link, and that is by
positioning the cursor just off the linked text and dragging across the link.

Is this not possible to implement? It was easily done in Netscape 4.X. Why the
move backward in functionality?

Max.

> pi
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
What you describe is a dupe, as I said before.

pi

*** This bug has been marked as a duplicate of 135410 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago17 years ago
Resolution: --- → DUPLICATE
For the record, bug 1214425 is the correct bug number of the above commit.
Blocks: 1214425
You need to log in before you can comment on or make changes to this bug.