Move History and Cookie button down in Browsing Privacy panel

RESOLVED FIXED

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: gasolin, Assigned: scottwu)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8673529 [details]
History and Cokie

As spec https://mozilla.app.box.com/s/axgrq6v7uousbd4274swqss6mi8pd2vi/1/4257534077/35064879857/1 shown in bug 1207717

Move History and Cokie section down in Browsing Privacy panel
(Reporter)

Updated

2 years ago
tracking-b2g: --- → backlog
Created attachment 8674721 [details] [review]
[gaia] scottwu:1214533-move-history-and-cookie-in-privacy > mozilla-b2g:master
(Assignee)

Updated

2 years ago
Assignee: nobody → scwwu
(Assignee)

Comment 2

2 years ago
Comment on attachment 8674721 [details] [review]
[gaia] scottwu:1214533-move-history-and-cookie-in-privacy > mozilla-b2g:master

Moved the buttons and also refactored to use dialog service. Added a few more integration tests.

Please take a look and let me know if any change is necessary. Thank Fred :)
Attachment #8674721 - Flags: review?(gasolin)
(Reporter)

Comment 3

2 years ago
Comment on attachment 8674721 [details] [review]
[gaia] scottwu:1214533-move-history-and-cookie-in-privacy > mozilla-b2g:master

Overall looks good! But please test with reset-gaia to make sure all production config is correct.
Attachment #8674721 - Flags: review?(gasolin)
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1203041
(Assignee)

Comment 5

2 years ago
Comment on attachment 8674721 [details] [review]
[gaia] scottwu:1214533-move-history-and-cookie-in-privacy > mozilla-b2g:master

I've excluded the dialog_service module in require.js config, but I found that not excluding it still worked on my device. Results from Treeherder didn't find errors either.
Attachment #8674721 - Flags: review?(gasolin)
(Reporter)

Comment 6

2 years ago
Comment on attachment 8674721 [details] [review]
[gaia] scottwu:1214533-move-history-and-cookie-in-privacy > mozilla-b2g:master

Looks great! thanks scott.
Attachment #8674721 - Flags: review?(gasolin) → review+
(Assignee)

Comment 7

2 years ago
Thanks Fred!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Updated

2 years ago
Depends on: 1216919

Updated

2 years ago
Summary: Move History and Cokie button down in Browsing Privacy panel → Move History and Cookie button down in Browsing Privacy panel

Updated

2 years ago
See Also: → bug 1220616
You need to log in before you can comment on or make changes to this bug.