Decommission Pulse machines

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: Other
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mcote, Assigned: w0ts0n)

Tracking

({spring-cleaning})

Details

(Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/1916] )

(Reporter)

Description

2 years ago
After we've migrated (perhaps after a day or two), we'll need to decommission the Pulse virtual machines.

Updated

2 years ago
Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/1916]
(Assignee)

Updated

2 years ago
Assignee: server-ops-webops → rwatson
(Reporter)

Updated

2 years ago
No longer blocks: 1205867
Depends on: 1205867
(Assignee)

Comment 1

2 years ago
:mcote please ping me in this bug when we are ready to go. 

Do you wants any monitoring for pulse.mozilla.org? Or if you've got it all handled through some other mechanism? The current nagios checks will need to be removed.
(Assignee)

Updated

2 years ago
Flags: needinfo?(mcote)
(Reporter)

Comment 2

2 years ago
Okay, we're good to turn off the old cluster.  Everything appears to be working smoothly in CloudAMQP.
Flags: needinfo?(mcote)
(Assignee)

Comment 3

2 years ago
Ok so here is what I've found for pulse*:

Domains: 
* pulse.mozilla.org 	A 	54.215.223.66 - Correct. Pointing at AWS. Leave this alone
* pulse.allizom.org 	A 	63.245.208.156 - allizom, dead can be decom'd? 
* pulse-old.mozilla.org 	A 	63.245.216.240 - dead link
* pulse-new.mozilla.org 	A 	63.245.217.87 - points to pulse.zlb.phx.mozilla.net
* pulse-dev.allizom.org 	A 	63.245.217.140 - points to pulse-dev-zlb.vips.phx1.mozilla.com


zlb's:
pulse-dev-zlb.vips.phx1.mozilla.com 	A 	63.245.217.140
pulse.zlb.phx.mozilla.net  	A 	63.245.217.87


Servers: 
pulse-app1.dev.dmz.phx1.mozilla.com 	A/PTR 	10.8.74.133 	
pulse-app1.dmz.phx1.mozilla.com  	A/PTR 	10.8.74.68 	
pulse-rabbit1.dev.dmz.phx1.mozilla.com 	A/PTR 	10.8.74.134 	
pulse-rabbit1.dmz.phx1.mozilla.com 	A/PTR 	10.8.74.69 	
pulse-rabbit2.dev.dmz.phx1.mozilla.com 	A/PTR 	10.8.74.135 	
pulse-rabbit2.dmz.phx1.mozilla.com 	A/PTR 	10.8.74.70 	
pulseadm1.private.phx1.mozilla.com 	A/PTR 	10.8.75.141

Stuff in puppet that might be of interest:
puppet/trunk/manifests/nodes/pulse.pp
puppet/trunk/modules/nagios/manifests/mozilla/services.pp
puppet/trunk/modules/webapp/files/pulse/etc-httpd/domains/pulse.mozilla.org.conf
puppet/trunk/modules/webapp/files/pulse-dev/etc-httpd/domains/pulse-dev.allizom.org.conf
puppet/trunk/modules/webapp/manifests/pulse.pp
puppet/trunk/modules/webapp/templates/pulse/bugzilla_simple_prod.config.erb
webops/ssl/certificates.ini

Looks like all the databases are stored locally.

C can you r+ the above please?
Flags: needinfo?(cliang)

Updated

2 years ago
Flags: needinfo?(cliang)

Updated

2 years ago
Keywords: spring-cleaning
(Assignee)

Comment 4

2 years ago
* Deleted all the zlb's
* removed from RHN
* removed dns entries
* killed the domains
* removed from puppet dashboard
* powered off machines
* removed from new relic
* filed netops bug for flows: 1217009
* filed VM bug for kwf the vm's: 1217008

Updated

2 years ago
Depends on: 1217008

Comment 5

2 years ago
CC'ing atoll, as a phx1 ZLB change was made.
Depends on: 1217009
(Assignee)

Comment 6

2 years ago
FYI I deleted from old/new phx.
(Assignee)

Comment 7

2 years ago
Other than waiting for the flows to be removed. This bug is completed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(In reply to Ryan Watson [:w0ts0n] from comment #6)
> FYI I deleted from old/new phx.

Thanks!
You need to log in before you can comment on or make changes to this bug.