All users were logged out of Bugzilla on October 13th, 2018

Support building with Clang

RESOLVED INVALID

Status

()

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: cocof35serveur, Unassigned)

Tracking

Trunk
All
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151012151721
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 10
Hardware: Unspecified → All
(Reporter)

Comment 1

3 years ago
Mozilla should support building wih Clang on windows in case Visual Studio doesn't work well or things like that...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 752004
(Reporter)

Comment 3

3 years ago
This is not realy a duplicate because i don't mean clang-cl i mean clang. Clang-cl use visual studio linker but i mean it could be great to have a second compiler like clang with it's own linker in case visual studio seem to be broken or anythings else.
Resolution: DUPLICATE → INVALID

Comment 4

3 years ago
Visual Studio works fine.  Bug 752004 tracks the work of porting Firefox to clang-cl (which is a cl compatible front-end to clang.)  We have no plans to support the gcc-style clang front-end on Windows.

Note that the LLVM project also has a link.exe compatible linker front-end which can be used instead of the MSVC linker but we haven't started porting to it yet.
You need to log in before you can comment on or make changes to this bug.