Screen will time out after 1 minute while recording video in the Camera app

RESOLVED DUPLICATE of bug 1212783

Status

Firefox OS
Gaia::Camera
RESOLVED DUPLICATE of bug 1212783
2 years ago
2 years ago

People

(Reporter: Marty, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark], URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8673792 [details]
logcat_camera-timeout.txt

Description:
If the user does not touch the device screen while recording a video, the device will still lock after the set time-out duration (default of 1 minute).  This will end automatically end the recording.

Note: This issue was previously reported and fixed in bug 1122811

1) Update a Aries to 20151014133333
2) Launch Camera
3) Record a video longer than 1 minute. 

Actual:
Screen will time-out / device will lockscreen after 1 minute has elapsed.

Expected:
Time-out does not occur while recording 

Environmental Variables:
Device: Aries 2.5
Build ID: 20151014133333
Gaia: df7683e4f7329c567deb487d11317578c6930246
Gecko: c3c027f6070db795bc59ba57795b8e36fde2471b
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Repro frequency: 5/5
See attached:  Video (URL), Logcat
(Reporter)

Comment 1

2 years ago
This issue DOES occur on the latest Flame 2.5 build.
Screen will time-out / device will lockscreen after 1 minute has elapsed.

Environmental Variables:
Device: Flame 2.5
BuildID: 20151014030205
Gaia: d400cda6bf0f8b30dcf7d7d71bfa61f29a3f1588
Gecko: 2387ada864282880d3a498d643abe3d8b887ee59
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

**************************************

This issue does NOT occur on the latest Flame 2.2 build.
Time-out does not occur while recording 

Environmental Variables:
Device: Flame 2.2
BuildID: 20151006032504
Gaia: 5dd95cfb9f1d6501ce0e34414596ef3dd9c2f583
Gecko: fc588eb28eab
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
This is on the radar and I think I have a fix that works over in bug 1212783.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1212783
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.