fullscreen switching doesn't work with certain window managers (olvwm, xmonad) since Firefox 41 (SeaMonkey 2.38)

RESOLVED DUPLICATE of bug 1189622

Status

()

Core
Widget: Gtk
RESOLVED DUPLICATE of bug 1189622
3 years ago
3 years ago

People

(Reporter: Matus UHLAR - fantomas, Unassigned)

Tracking

41 Branch
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

User Story

(In reply to gotyaoi from comment #4)
> Finally figured it out on my end. Needed to support the _NET_WM_STATE
> protocol, which xmonad does not do my default. Installed the fullscreen hook
> from this extension:
> http://xmonad.org/xmonad-docs/xmonad-contrib/XMonad-Hooks-EwmhDesktops.html,
> and things seem to be working now. Not sure how this would relate to olvwm
> though...


See Also Bug 1189622
(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:41.0) Gecko/20100101 SeaMonkey/2.38
Build ID: 20151008185546

Steps to reproduce:

pressing F11 or choosing "View/Full Screen" in menu does nothing with olvwm.
2.35 worked nicely. is there a possibility to revert to the old behaviour if window manager is not known?

Comment 1

3 years ago
Does this also happen with Firefox 41?

Comment 2

3 years ago
I'm experiencing the same behavior on firefox 41.0.1, under xmonad. I tested with some older releases, and it was working up to 40.0.3, but not after. Some odd details, f11 and the "Full Screen" button in the hamburger menu seem to have no effect whatsoever, but if I hit alt and use the full screen option in the view menu, then restart firefox, it starts fullscreen, but at this point nothing besides editing xulstore.json will get it out of fullscreen. Additionally, any kind of html5 fullscreen video does not actually fill the screen, but leaves the firefox toolbar and tab bar uncovered.
(Reporter)

Comment 3

3 years ago
Yes, it happens with FF 41.0.2 here.

A new symptom has appeared: when I started SM 2.38 under olvwm today, it started in the pseudo-fullscreen mode and I could not turn that off.

Updated

3 years ago
Summary: fullscreen switching doesn't work with olvwm since 2.38 → fullscreen switching doesn't work with certain window managers (olvwm, xmonad) since Firefox 41 (SeaMonkey 2.38)

Updated

3 years ago
Component: UI Design → Widget: Gtk
OS: Unspecified → Linux
Product: SeaMonkey → Core
Hardware: Unspecified → All
Version: SeaMonkey 2.38 Branch → 41 Branch

Comment 4

3 years ago
Finally figured it out on my end. Needed to support the _NET_WM_STATE protocol, which xmonad does not do my default. Installed the fullscreen hook from this extension: http://xmonad.org/xmonad-docs/xmonad-contrib/XMonad-Hooks-EwmhDesktops.html, and things seem to be working now. Not sure how this would relate to olvwm though...

Updated

3 years ago
User Story: (updated)
Depends on: 1189622
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
No longer depends on: 1189622
Resolution: --- → DUPLICATE
Duplicate of bug: 1189622
You need to log in before you can comment on or make changes to this bug.