Adding duplicate entries to the CAB...

VERIFIED FIXED in mozilla1.0

Status

P2
normal
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: mscott, Assigned: cavin)

Tracking

({regression})

Trunk
mozilla1.0
x86
Windows 2000
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Every time I read a message or send a message from the same email address, I'm
getting an extra entry in my CAB. For instance right now I have 25 entries for
Scott Putterman and another 10 entries for sspitzer@netscape.com. 

It looks like when we add an entry we are no longer catching the fact that we
already have it and we end up with duplicates.
(Reporter)

Comment 1

17 years ago
nominating.
Keywords: nsbeta1

Comment 2

17 years ago
I can't duplicate this problem on demand, although I do see duplicate entries in
my address book. Do you have any details on getting the problem to occur?
ok, I know what's going on.

the problem is with cards with any capital letters.

say you get email from SethSpitzer@foo.com, and you collect it.
each time you get one from that address, it will add a duplicate.

there is a bug in the addressbook code that makes it so when you search based on
email, we must be doing something wrong with case sensitivity.

I think there might be an existing bug on this same problem, but it wasn't CAB
related.

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P2
Target Milestone: --- → mozilla1.0
taking, I'll get to this as I caused the regression.
Assignee: racham → sspitzer
Status: ASSIGNED → NEW
Keywords: regression
Target Milestone: mozilla1.0 → mozilla0.9.9
*** Bug 125468 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 6

17 years ago
nsbeta1- per ADT triage, ->1.2, blocks 'miracle bug' 122274
Blocks: 122274
Keywords: nsbeta1+ → nsbeta1-
Target Milestone: mozilla1.0 → mozilla1.2
reeling back in, this might relate to some other nsbeta1+ bugs, like #62084
Blocks: 62084
Target Milestone: mozilla1.2 → mozilla1.0
I think cavin has relatively simple patch for this (and bug #128535)

his patch will leave us with a different bug, but I'd argue it's better than it 
is now.

cavin's patch will make it so we never do case insensitive searches.  the down 
side is you could still end up with duplicates in the CAB, but only when you 
receive emails that don't match.

sspitzer@netscape.com, Ssspitzer@netscape.com might be in there, but
Sspitzer@netscape.com will only be in there once, no matter how many times you 
receive mail from me.

I think we can easily fix this at the same time cavin fixes 128535

re-assign to cavin

back to nsbeta1 for re-evaluation given its relationship to 128535
Assignee: sspitzer → cavin
Status: ASSIGNED → NEW
Keywords: nsbeta1- → nsbeta1
(Assignee)

Updated

17 years ago
No longer blocks: 128535
(Assignee)

Comment 9

17 years ago
Moving 128535 from blocking to dependency.
Depends on: 128535

Comment 10

17 years ago
Discussed in Mail News bug mtg w Engineering Mktng PjM.  Decided to plus the
bug.  Removing blockage of 122274 also.
No longer blocks: 122274
Keywords: nsbeta1 → nsbeta1+
(Assignee)

Comment 11

17 years ago
Marking fixed as patch to bug 128535 does fix it. See Comment #8 for more details.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 12

17 years ago
Trunk build 2002-03-22: WinMe, Linux RH 7.1, Mac 9.1
Verified Fixed.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
To the best of my knowledge this bug still exists in the main code.  To get it fixed please go to bug 129393 https://bugzilla.mozilla.org/show_bug.cgi?id=129393 and click the vote button to raise its level of importance.
You need to log in before you can comment on or make changes to this bug.