[Stingray][Home] Filter should also search cards inside folders

RESOLVED FIXED

Status

Firefox OS
Gaia::TV::Home
P1
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: rexboy, Assigned: rexboy)

Tracking

unspecified

Firefox Tracking Flags

(b2g-v2.5 fixed)

Details

(Whiteboard: [ft:conndevices])

Attachments

(1 attachment)

When we switch filters, the cards inside folders doesn't appears anywhere else besides "all" filter. By the latest ux spec, we need to put out those cards too - as one line (e.g. omit the folder structure when filtering)
Created attachment 8674047 [details] [review]
[gaia] rexboy7:1214992-filter-folder-cards > mozilla-b2g:master
Assignee: nobody → rexboy
Blocks: 1193692
Comment on attachment 8674047 [details] [review]
[gaia] rexboy7:1214992-filter-folder-cards > mozilla-b2g:master

Hi Yifan:

This feature is written in spec but not included in 2.5. Would you mind review it? Since it's not a blocker you can do it when you are available.
Attachment #8674047 - Flags: review?(yliao)
Comment on attachment 8674047 [details] [review]
[gaia] rexboy7:1214992-filter-folder-cards > mozilla-b2g:master

Thanks!
Attachment #8674047 - Flags: review?(yliao) → review+
Comment on attachment 8674047 [details] [review]
[gaia] rexboy7:1214992-filter-folder-cards > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: The behavior is not aligned to UX spec.
[Testing completed]: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=96a1f9bcf70ba4855c62d4b030a7b18f664274d3
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none
Attachment #8674047 - Flags: approval-gaia-v2.5?
Comment on attachment 8674047 [details] [review]
[gaia] rexboy7:1214992-filter-folder-cards > mozilla-b2g:master

Approved for 2.5 uplift.
Thanks
Attachment #8674047 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.