[e10s] View Page Source doesn't work in about:newtab as "Error: View source browser's remoteness mismatch"

RESOLVED DUPLICATE of bug 1213693

Status

()

Toolkit
View Source
RESOLVED DUPLICATE of bug 1213693
2 years ago
2 years ago

People

(Reporter: magicp, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox41 unaffected, firefox42 unaffected, firefox43 affected, firefox44 affected, firefox-esr38 unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8674160 [details]
view-page-source-does-not-work-in-about-newtab.png

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20151014030223

Steps to reproduce:

1. Run Aurora or Nightly with e10s
2. Open New Tab (about:newtab)
3. Select View Page Source in context menu


Actual results:

Another New Tab is opened, and an error is displayed in Browser Console

Error: View source browser's remoteness mismatch ViewSourceBrowser.jsm:231:13
updateBrowserRemoteness() ViewSourceBrowser.jsm:231
loadViewSource() ViewSourceBrowser.jsm:191
gViewSourceUtils.viewSourceInBrowser() viewSourceUtils.js:99
BrowserViewSourceOfDocument/viewInternal() browser.js:13273
BrowserViewSourceOfDocument() browser.js:13290
BrowserViewSource() browser.js:13303
oncommand() browser.xul:1




Expected results:

View Page Source works in about:newtab on e10s
(Reporter)

Updated

2 years ago
Blocks: 516752
Has STR: --- → yes
status-firefox41: --- → unaffected
status-firefox42: --- → unaffected
status-firefox43: --- → affected
status-firefox44: --- → affected
status-firefox-esr38: --- → unaffected
Component: Untriaged → View Source
OS: Unspecified → All
Product: Firefox → Toolkit
Hardware: Unspecified → All
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1213693
You need to log in before you can comment on or make changes to this bug.