View source in a new tab is blank

RESOLVED DUPLICATE of bug 1165309

Status

()

Toolkit
View Source
RESOLVED DUPLICATE of bug 1165309
2 years ago
2 years ago

People

(Reporter: evilpie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
The new view-source in a tab doesn't work for me on Nightly with e10s enabled. The Browser Console shows this error: "TypeError: contentWindow is null viewSource-content.js:227:11"

Interestingly it does seem to work when I enter "view-source:http://example.org"  in the urlbar directly. However opening view source with the context-menu doesn't work.
What URL were you testing on?  Was it a chrome page, like "about:addons"?
Flags: needinfo?(evilpies)
(Reporter)

Comment 2

2 years ago
Nope, both times I tried http://example.org/.
Flags: needinfo?(evilpies)
Hmm, I am not seeing this error in a fresh build of fx-team.

Could you try a clean profile, to be sure it's not something like a config setting or add-on?
Flags: needinfo?(evilpies)
(Reporter)

Comment 4

2 years ago
I think you might be onto something. View-source does work in a new clean profile. It doesn't work even in safe-mode with my existing profile.
Flags: needinfo?(evilpies)
On IRC, we discovered :evilpie has processCount > 1.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1165309
You need to log in before you can comment on or make changes to this bug.