favicon for 304 redirects dont' work in bookmarks

NEW
Unassigned

Status

17 years ago
2 years ago

People

(Reporter: alecf, Unassigned)

Tracking

(Blocks: 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox])

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I have a personal toolbar button for http://www.news.com/ - recently they
started redirecting to http://news.com.com/ (stupid c|net!)

Ever since then, my toolbar button's icon has disappeared, and I don't get the
favicon that they have

I've seen this on other redirects as well, such as http://www.excite.com/ and
http://www.amazon.com/

I think we need to somehow track redirects and update icons appropriately...
it's a hard problem, I guess we need to somehow know if the current icon came
from a redirected url, and if so set the icon for the original url as well.
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → Future

Updated

16 years ago
Blocks: 120352

Comment 1

16 years ago
*** Bug 128457 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
*** Bug 232976 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
see bug 232976 comment 1 for an explanation
Product: Browser → Seamonkey

Updated

13 years ago
Depends on: 89419

Comment 4

13 years ago
hey ben, any eta on this four (4) year old bug :p

Comment 5

12 years ago
Good luck with that.  There are a ton of other favicon bugs in the queue.  It's almost bad enough to toss out the feature completely.

Comment 6

11 years ago
The summary should say 301, not 304.
Assignee: bugs → nobody
Status: ASSIGNED → NEW
Priority: P3 → --
QA Contact: claudius → bookmarks
Target Milestone: Future → ---

Comment 7

8 years ago
Please do not release Firefox 4 without fixing this 1st.

Comment 8

8 years ago
Related bugs:
389642 Default favicon shown for a redirected URL 
423127 Favicon is lost when modifying a bookmark's URL

PLEASE PLEASE PLEASE FIX BOOKMARK FAVICONS!!

Comment 9

6 years ago
Still valid, quick steps to reproduce
1) Add bookmark for http://www.news.com/
2) Click on it, get redirected to http://news.cnet.com/
Expected results:
Bookmark get favicon from visited site
Actual results:
Bookmark's default favicon doesn't change
OS: Windows 2000 → All
Hardware: x86 → All
Whiteboard: [2012 Fall Equinox]
Created attachment 8785628 [details]
Clipboard.png

With the latest round of changes this looks resolved now. Rainer can you try it. I think we can close the bug.
Flags: needinfo?(RainerBielefeldNG)

Comment 11

2 years ago
I haven't a clue what the problem might be here.

But my test results is: Still REPRODUCIBLE with official en-US SeaMonkey 2.48a1  (NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0 Build 20160804000913  (Default Classic Theme) on German WIN7 64bit (if my assumption what the problem might be is correct)

1. Open this bug report
2. In Bookmarks Menu Create a new Folder "FaviconTest" via Bookmarks Panel in
   Siedbar
3. Drag and drop Favicon of this page to new Folder "FaviconTest"
   » Bugzilla Favicon and Bug Summary shown in bookmarks as expected
3. ˋRichtclick link <http://www.news.com/> in original report → Copy link 
   locationˊ
4. ˋrightclick new Bookmark → Properties → replace URL with clipboard contents 
   and rename Bookmark to "FaviconTest"ˊ
5. ˋRightclick new Bookmark in Sidebar Bookmarks Panel → Open in new TAB → 
   select new TAB if necessaryˊ
   » You will see <http://www.cnet.com/news/>
   » in Sidebar Bookmarks Panel you still see Bugzilla favicon for new Bookmark
6. Menu ˋFile → New → Browser Windowˊ
   » New Browser Window with Default Page will be opened
7. Check New Bookmark "FaviconTest" in Sidebar Bookmarks Panel
   » Shows SeaMonkey default Favicon instead of something useful             :-(
8. Menu Bookmarks → Manage Bookmarks → Type "FaviconTest" to search input lineˊ
   » Found new bookmark shows SeaMonkey default Favicon instead of 
     something useful                                                        :-(

a) I think I did the same test like Phoenix in Comment 9
b) With STR from Comment 9 I still can reproduce the problem
   But as I said at the beginning, I don't whether I did the correct test.
c) I think "Bug 232976 - Background loading of toolbar icons should follow 
   redirects when possible" has a better Summary
Flags: needinfo?(RainerBielefeldNG)

Comment 12

2 years ago
d) I also tried with 'rightclick → Bookmark this link' in Step 3:
   No success, Favicon will not be updated
e) I also tried with newly created User Profile:
   No success, Favicon will not be updated
You need to log in before you can comment on or make changes to this bug.