Status

mozilla.org Graveyard
Server Operations
--
blocker
RESOLVED INVALID
16 years ago
3 years ago

People

(Reporter: Akkana Peck, Assigned: Akkana Peck)

Tracking

Details

(Assignee)

Description

16 years ago
Last week I had no problems pulling and building using make -f client.mk, but
this week (starting Tuesday; didn't try Monday) this hangs forever, in the first
pull command:
cvs -q -z 3 co -P mozilla/client.mk mozilla/build/unix/modules.mk

If I edit client.mk and remove the -z 3 flag, then my pull works.

Redhat 7.2, cvs-1.11.1p1-3

I'm not 100% sure that I've done successful updates under 7.2 before: I only
upgraded it to 7.2 early last week, and I know I've done several builds since
then, but it's possible that they were all pulls into fresh trees.

-z 1 and -z 2 also fail when I try them by hand.
My pulls using cvs 1.11.1p1-3 on a stock RH 7.2 box work fine.  I'm also using
ext3 fs, not that it should matter.  Someone needs to find out what's happenning
on the server side when this happens.
Assignee: seawood → daruszka
Component: Build Config → Server Operations
Product: Browser → mozilla.org
QA Contact: granrose → endico
(Assignee)

Comment 2

16 years ago
I'm also pulling to an ext3 filesystem.
(Assignee)

Comment 3

16 years ago
As of today, I can't pull from mozilla.org from my home machine over DSL (the
network is working fine, I have no trouble downloading a release build, getting
IRC or mail, or surfing the web) even with -z 3 turned off.  make -f fast-update
hangs somewhere in mail/news; pulling via the more normal make -f client.mk also
hangs (I've been waiting 25 minutes for my third try).

This has become a blocker since I can't update my tree.  Please, I need a
workaround if not a real fix!
Severity: normal → blocker
(Assignee)

Comment 4

16 years ago
Updating summary since it's not just -z3 (in fact, just now I tried -z 3 and was
able to pull a few files before it hung again).

strace on the process shows this when it hangs:

[ ... ]
open("CVS/Tag", O_RDONLY)               = -1 ENOENT (No such file or directory)
open("CVS/Entries", O_RDONLY)           = 5
fstat64(5, {st_mode=S_IFREG|0644, st_size=198, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x4001a000
read(5, "/.cvsignore/1.1/Sat Dec 29 03:37"..., 4096) = 198
read(5, "", 4096)                       = 0
close(5)                                = 0
munmap(0x4001a000, 4096)                = 0
open("CVS/Entries.Log", O_RDONLY)       = -1 ENOENT (No such file or directory)
unlink("CVS/Entries.Static")            = -1 ENOENT (No such file or directory)
read(4, 

... and just sits there with the cursor after the four-comma-space.

Aha -- after about ten minutes it got a few files, and now it's hung on:

access("Makefile.in", F_OK)             = -1 ENOENT (No such file or directory)
open(".new.Makefile.", O_WRONLY|O_CREAT|O_TRUNC, 0777) = 5
read(4, 

Then ten minutes more with no strace activity whatsoever.

Is there any other query I can do that might help pin this down?
Summary: Pull fails because -z 3 doesn't work (RH 7.2) → Pull fails doesn't work (RH 7.2)

Comment 5

16 years ago
i'm helping akkana figure this out. I suspect that she's having some
kind of network lossage. a firewall or something.
(Assignee)

Comment 6

16 years ago
It does seem to be something connected with RH 7.2.  I can pull on another
machine (RH 7.1) from the same network.  (Unfortunately, I can't downgrade my
build machine because RH 7.1's X can't drive this video card.)

I tried booting a different kernel, and turning off ipchains/iptables (which I
had said no to at install time, but RH installed them anyway) but no joy yet.
akk: the RH errata packages released yesterday include 4.1.0 for RH7.1

Hanging for 10 minutes is normal. Its mainly because cvs sucks, and teh cvs
server is really overloaded (theres a bug on that which hasn't been touched in a
while)

Comment 8

16 years ago
Akkana verified that she really does have a network problem.
Assignee: daruszka → akkana
(Assignee)

Comment 9

16 years ago
It turns out that this was a hardware problem.  My sound card was interfering
with the network card -- not enough to stop networking, just enough that cvs
didn't work (or worked without -z 3 but not with it) and that ftp/http transfers
from some machines hung under some circumstances.  I still don't know why it
started out almost unnoticable and got steadily worse.  But on a hunch, I pulled
my sound card, and it looks like CVS pulls are working again.

Very strange ...  Dawn, thanks so much for the help in tracking this down!
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Summary: Pull fails doesn't work (RH 7.2) → Pull fails (RH 7.2)
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.