Publishing Error in Webmaker

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
3 years ago
2 years ago

People

(Reporter: sxean, Unassigned)

Tracking

Details

(Whiteboard: [2.5-Daily-Testing][Spark], URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
When trying to publish a website made with Webmaker by clicking on the Share Icon 
a red banner appears underneath stating "Publishing Error". 

Repro Steps:
1) Update a Aries to 20151015110122
2) Go to Settings >Developer>FUll DevTools and Enable. 
3) Go to WebMaker > Make > pick any Template and Edit (Start Building). 
4) After making Edits, go to the Share Icon and press. 

Actual:
When pressing the Share Icon to Publish, a vague error message stating: " There was a publishing Error ". 

Expected:
When pressing the Share Icon to Publish, a message stating, "a connection to HOST is needed to publish Website" is 
expected...or something to that effect. 

REPRO: 
Environmental Variables:
Device: Aries 2.5
Build ID: 20151015110122
Gaia: 40ae7c292a36156458c66712b4bd61ecbe69272a
Gecko: e193b4da0a8c1025aa76a403c64663ff1cd41709
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

RESULT: When pressing the Share Icon to Publish, a vague error message stating: "There was a publishing Error". 


Repro frequency: (5/5)
See attached: (screenshot, video clip, logcat.)
(Reporter)

Comment 1

3 years ago
Created attachment 8674520 [details]
publishingerror.png
(Reporter)

Comment 2

3 years ago
Created attachment 8674521 [details]
PublishingError.txt
(Reporter)

Comment 3

3 years ago
NO REPRO: 
Environmental Variables:
Device: Flame 2.5
BuildID: 20151015030226
Gaia: 40ae7c292a36156458c66712b4bd61ecbe69272a
Gecko: e193b4da0a8c1025aa76a403c64663ff1cd41709
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

RESULT: N/A 
NOTE: Downloadable Webmaker from Marketplace for latest Flame Build does not have the option to publish.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-master: --- → affected
Flags: needinfo?(jmercado)
Whiteboard: [2.5-Daily-Testing][Spark]
Naoki do we block on Webmaker issues? This one seems pretty bad.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
status-b2g-master: affected → ---
Component: Developer Tools → General
Flags: needinfo?(jmercado) → needinfo?(nhirata.bugzilla)
Product: Firefox OS → Webmaker
QA Contact: brett
Webmaker are not 2.5 blockers as there's no release plans for webmaker in 2.5 from what I recall now.
Flags: needinfo?(nhirata.bugzilla)
Closing this bug as part of the Deprecation of the Webmaker Product on Bugzilla. If this issue needs to re resolved in another manner, re-file it in a new Product or find the associated project on Github (http://github.com/mozilla) and file an issue there.

see bug 1347718
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.