Closed Bug 1215347 Opened 6 years ago Closed 4 years ago

Calling console.profile() and console.profileEnd() causes Firefox to crash

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect, P3)

41 Branch
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: sworddragon2, Unassigned)

References

(Depends on 1 open bug)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20151003161951

Steps to reproduce:

1. Start Firefox.
2. Go to the menu bar -> Tools -> "Web Developer" -> "Web Console".
3. Execute "console.profile();".
4. Execute "console.profileEnd();".


Actual results:

Firefox crashes.
Can you please provide links to the crash reports show in about:crashes?
Component: Untriaged → Developer Tools: Performance Tools (Profiler/Timeline)
Flags: needinfo?(sworddragon2)
Firefox claims that about:crashes is not a valid address.
Flags: needinfo?(sworddragon2)
Ah, maybe because it's from your distro. That's unfortunate.
Yes, I'm using Firefox from the Ubuntu repository. But I'm wondering then why they removed about:crashes.
Thank you for reporting this! I cannot recreate -- please reopen if you have steps to reproduce or a crash report!
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
Depends on: 1240249
Currently this bug can't for sure be reproduced anymore because of bug #1240249.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Triaging. Filter on ADRENOCORTICOTROPIC (yes).
Priority: -- → P3
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago4 years ago
Resolution: --- → WORKSFORME
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.