Remove unlisted search plugins from en-US (creativecommons, answers)

RESOLVED FIXED in Firefox 44

Status

()

Firefox
Search
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

38 Branch
Firefox 44
Points:
---

Firefox Tracking Flags

(firefox44 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
The list of search plugins actually installed for the en-US locale is in browser/locales/en-US/searchplugins/list.txt. It doesn't contain some of the files that can be found in browser/locales/en-US/searchplugins, and as a result, those files are installed when using `mach build faster` because it doesn't rely on that list.txt file.

We might as well remove those unlisted search plugins. They can be found in the repository history anyways, if necessary at some point in the future.
(Assignee)

Comment 1

3 years ago
Created attachment 8674707 [details] [diff] [review]
Remove unlisted search plugins

For reference, they were removed from list.txt in bug 603298.
Assignee: nobody → mh+mozilla
Attachment #8674707 - Flags: review?(dolske)
A few notes:
* Searchplugins in browser/locales/en-US/searchplugins can be used by other locales.
* ddg is not in list.txt (bug 1105092) but it's shipping in all locales

I think you're actually looking at answers.xml and creativecommons.xml, in which case this bug is a dupe of bug 1068456.

If someone can confirm bug 1068456 comment 6 from the build side, I think we can remove them.
(Assignee)

Comment 3

3 years ago
The code from bug 1073212 is still there and will emit an info message, not an error, for a listed search plugin that doesn't exist anywhere.
Comment on attachment 8674707 [details] [diff] [review]
Remove unlisted search plugins

Seems fine, but I don't know this code very well (especially wrt comment 2). Drew, maybe?
Attachment #8674707 - Flags: review?(dolske) → review?(adw)

Updated

3 years ago
Attachment #8674707 - Flags: review?(adw) → review+
https://hg.mozilla.org/mozilla-central/rev/70c0db5f0d4f
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox44: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 44
Duplicate of this bug: 1068456
Summary: Remove unlisted search plugins → Remove unlisted search plugins from en-US (creativecommons, answers)
You need to log in before you can comment on or make changes to this bug.