If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Missing posts in threads?

VERIFIED DUPLICATE of bug 64476

Status

MailNews Core
Networking: NNTP
VERIFIED DUPLICATE of bug 64476
16 years ago
9 years ago

People

(Reporter: 石庭豐 (Seak, Teng-Fong), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.7+)
Gecko/20020114
BuildID:    20020114

 Actually, I don't know the exact nature of this problem.  Take a look at the
attached image.  It's captured from netscape.public.mozilla.wishlist.  Here,
Mozilla is in "Threads With  Unread" mode and the thread "Add search engines"
has only two posts (well, at least that's what it seems to me).  But as you can
see, the little icon to the left of the triangle (how's it called by the way?)
indicates that the threads isn't all read because it has the little green arrow
on it!!  So it seems like there're some missing posts in the thread.  Is this
really the case?  Pressing the "Next" button doesn't get me any further.

So next time when I get back to this newsgroup, the thread will still be here
and the same  no matter how I press the "Next" button, the thread just remains.

There's also another problem which seems to be relevant to this one.  Sometimes
Mozilla shows that there are still some unread posts.  But pressing "Next"
doesn't show anything.  At this time, I have to use the menu "Message > Mark >
All read", sorta to reset the counter of posts.

Reproducible: Always
(Reporter)

Comment 1

16 years ago
Created attachment 66241 [details]
An example of "broken thread"
Created attachment 66351 [details]
Screenshot of Outlook Express' thread.
Teng-Fong, are you sure you're not seeing bug 64476?.  As you can see by the
screenshot, this thread is indeed only 2 message deep.
Summary: Missing posts in threads? → Missing posts in threads?
(Reporter)

Comment 4

16 years ago
Maybe.  But I don't understand what "false positive" means?  This term doesn't
make any sense to me.
Anyhow, as you can see from my screen capture, there's a green arrow on the
thread icon even though the thread is all read.
Any idea?
Read bug 64476 carefully.  A 'false positive' means that the client thinks there
is an unread message there when there really isn't.

*** This bug has been marked as a duplicate of 64476 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup.  the key here is Thread with Unread.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.