Input fields have ugly inner box-shadow

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Feedback
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: wilsonpage, Unassigned)

Tracking

({foxfood})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bzlite])

Attachments

(6 attachments)

(Reporter)

Description

2 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Select sites that have custom <input> styling have broken looking inner box-shadow.
(Reporter)

Comment 1

2 years ago
Created attachment 8674807 [details]
system-b2g-application.ini
(Reporter)

Comment 2

2 years ago
Created attachment 8674808 [details]
dev-log-main.log
(Reporter)

Comment 3

2 years ago
Created attachment 8674809 [details]
properties.log
(Reporter)

Comment 4

2 years ago
Created attachment 8674810 [details]
screenshot.png
QAnalysts, 

Can you confirm if this is only on Google or on all websites/forms?

Thanks
Keywords: qawanted
(Reporter)

Comment 6

2 years ago
Created attachment 8675733 [details]
facebook
(Reporter)

Comment 7

2 years ago
(In reply to Mahendra Potharaju [:mahe] from comment #5)
> QAnalysts, 
> 
> Can you confirm if this is only on Google or on all websites/forms?
> 
> Thanks

This is not on all web-forms but on several major sites (Google, Facebook, etc). I believe perhaps it's a particular Gecko CSS property that they are not targeting. Either way, it looks broken on fxos and not on other mobile browsers.
Created attachment 8677676 [details]
screenshots from today's build (bug not occurring)

I can confirm that this issue is no longer occurring on latest. On a build on the same date as reported (comment 1, which is a 10/2 build), I was seeing this issue on maps.google.com or facebook app. With today's build, they're not occurring. See attached screenshots for comparison.

Bug reproduces on:
Device: Aries 2.5
BuildID: 20151002110438
Gaia: 9a682cb7bc8b7fde624a9b2b3c2d64415a08b04b
Gecko: 5f16c6c2b969f70e8da10ee34853246d593af412
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Bug does NOT reproduce on:
Device: Aries 2.5
BuildID: 20151022105033
Gaia: 29ce8ec8606e59f582375234440812b046346513
Gecko: 76bd0c01d72e64ca4f261ffdb2652a91f961e930
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Wilson, can you check if this still happens on your phone? If not, we can close it as Works For Me. 

Thanks
Flags: needinfo?(wilsonpage)
(Reporter)

Comment 10

2 years ago
This appears fixed now. Thanks!
Flags: needinfo?(wilsonpage)
Thanks Wilson. Closing it as Works for me.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.