[RFE] MMB click should open tab to the right, not at end

VERIFIED DUPLICATE of bug 105722

Status

SeaMonkey
Tabbed Browser
--
enhancement
VERIFIED DUPLICATE of bug 105722
17 years ago
7 months ago

People

(Reporter: Matthew Mastracci, Assigned: jag (Peter Annema))

Tracking

Trunk
Future
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
When middle-mouse clicking a link in a tab, the tab opens at the end of the 
list of tabs.  When I then close the tab using the MMB again, I go to the 
second-last tab, not back to where I was!  

Here is an example to illustrace (/ tab \ specifies the active tab)

CURRENT BEHAVIOUR:

/ Mozilla  / Mozillazine \ Slashdot \

I then MMB-click a link in mozillazine to quickly check another site:

/ Mozilla / Mozillazine / Slashdot / Other Site \

Then I MMB-click the other site tab to close it:

/ Mozilla / Mozillazine / Slashdot \

As you can see, I'm on the slashdot tab now!  If you browse with lots of tabs 
like I do, you quickly get lost and can't find your old tab.

EXPECTED BEHAVIOUR:

/ Mozilla  / Mozillazine \ Slashdot \

I then MMB-click a link in mozillazine to quickly check another site:

/ Mozilla / Mozillazine / Other Site \ Slashdot \

Then I MMB-click the other site tab to close it:

/ Mozilla / Mozillazine \ Slashdot \

As you can see, I'm where I was before.  Opening the tab in the spot just to 
the right ensures that I end up back when closing it.
(Assignee)

Comment 1

17 years ago
-> future
Target Milestone: --- → Future
(Reporter)

Comment 2

17 years ago
Any hints on where to start to implement this myself?  If it's only XUL/js, it
might be something I could take a look at.

Comment 3

17 years ago
There's too much debate about where should be placed new tabs in bug 105722
"Closing tabs should return to 'parent' tab." which focus the real intention of
this bug, to return to the previous tab.

dupping

*** This bug has been marked as a duplicate of 105722 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.