Highlighting an url and ctrl+left clicking should open the URL

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
17 years ago
14 years ago

People

(Reporter: pab, Assigned: mpt)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Hi..
It's possible to press CTRL+Mousebutton1 instead of Mousebutton3 to open a new
Window/Tab .. a VERY nice feature for Notebook users..

..and when you highlight an URL (eg. http://www.mozilla.org (url without <a
href..) ) and hit Mousebutton3 Mozilla will load the URL.. i think it would be
nice when you could also press CTRL+Mousebutton1

...at the moment, CTRL+Mousebutton1 does something weired like 'selecting table
cells'..

bye

Comment 1

17 years ago
I dislike the idea of middle-click-pasting and occasionally use Ctrl+click to 
select table cells, so I vote against this bug.  I also object to this bug for 
the same reason I object to bug 10080: it would encourage content authors to 
include URLs in their documents without turning them into hyperlinks.
Summary: Highlighting an url and pressing CTRL+Mousebutton1 should open the URL → Highlighting an url and ctrl+left clicking should open the URL
(Reporter)

Comment 2

17 years ago
> it would encourage content authors to include URLs in their documents without
turning them into hyperlinks.

Yes, but remember: sometimes you're reading plaintext files in mozilla and then
such a function is very usefull...

It was just an idea .. and on a laptop it's a pain to press mouse1 and 2
together.. but CTRL + Mouse1 is no problem.. (or Alt+Mouse1)

Updated

17 years ago
Depends on: 10080

Comment 3

17 years ago
The right way to make URLs in plain text documents usable is bug 39042, "Display
text/plain and *.txt using stream converters".  This method would be very hard
to discover.
No longer depends on: 10080

Comment 4

17 years ago
> The right way to make URLs in plain text documents usable is bug 39042, "Display
> text/plain and *.txt using stream converters".  This method would be very hard
> to discover.

I completely agree.

For HTML, bug 10080 is the right one.
(But I think, Jesse, you misunderstood that bug. That bug doesn't turn
non-linkified URLs in HTML documents automatically into links. I agree that this
would be a bad idea, for several reasons.)

IMO, this bug should be WONTFIX.


> ..and when you highlight an URL (eg. http://www.mozilla.org (url without <a
> href..) ) and hit Mousebutton3 Mozilla will load the URL..

What's happening here is actually a copy, paste and a load triggered by paste
into the content area. I think, that works only on Unix and IMO it's a bad idea.

Comment 5

17 years ago
*** Bug 136277 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
Somebody WONTFIX this then.
(Reporter)

Comment 7

17 years ago
-> WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Updated

16 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.