Crash if clicking down arrow in text field followed by an image input both use CSS position

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
--
critical
RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Gadi Melamed, Assigned: rods (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)
BuildID:    20011019

In the 
page 'http://www.geocities.com/SiliconValley/Circuit/3329/bugs/netscape_crash.ht
ml' there are 2 input fields - text and image. Both use CSS absolute position 
attribute. If you enter the text field and click on the right (or down) arrow 
key, Netscape crashes.


Reproducible: Always
Steps to Reproduce:
1. Enter the given URL.
2. Enter the text field.
3. Click the arrow down key.

Actual Results:  Netscape crash

Try the following HTML (where 'mygif.gif' exists):
<html>
   <body>
	<input type="text" style="position: absolute; left: 200; top: 10; 
width: 50; height: 20; " />
	<input type="image" src="mygif.gif" style="position: absolute; top: 10; 
left: 255; "/>
   </body>
</html>

Comment 1

16 years ago
WorksForMe   Build: 2002021203  OS:WinNT

Comment 2

16 years ago
Works for me, Windows XP build 2002021303.

Comment 3

16 years ago
WorksForMe   Build: 2002022503  OS:Win98se
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

16 years ago
QA Contact: madhur → tpreston
You need to log in before you can comment on or make changes to this bug.