Closed Bug 1215696 Opened 5 years ago Closed 5 years ago

update rust mp4parser to v0.1.1

Categories

(Core :: Audio/Video: Playback, defect, P2)

42 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla44
Tracking Status
firefox44 --- fixed

People

(Reporter: rillian, Assigned: rillian)

References

Details

Attachments

(2 files)

Kinetik's fix for only parsing the 'ftyp' box.
Good catch figuring out the 'zero tracks' thing. Thanks!
Attachment #8675154 - Flags: review?(kinetik)
We give the correct answer to the 'street.mp4' test now.
Attachment #8675156 - Flags: review?(kinetik)
Attachment #8675154 - Flags: review?(kinetik) → review+
Attachment #8675156 - Flags: review?(kinetik) → review+
BTW: remember to update Cargo.toml to 0.1.1.
Flags: needinfo?(giles)
Priority: -- → P2
Hrm, it happened a second time after my backout. Maybe it's some clobber-needed thing?
Trying again with clobber.
Looks like the clobber did the trick. We don't have proper dependency generation for rust (patches pending) but I didn't expect that to be a problem because the top-level crate source changed. Strange.
(In reply to Matthew Gregan [:kinetik] from comment #3)
> BTW: remember to update Cargo.toml to 0.1.1.

Thanks, I forgot to do that, and then couldn't upload the package on Friday anyway because of https://github.com/rust-lang/cargo/issues/2063. I moved the tag and pushed the changes yesterday. https://crates.io/crates/mp4parse/0.1.1
You need to log in before you can comment on or make changes to this bug.