Brotli doesn't work over SPDY

RESOLVED FIXED in Firefox 44

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: piotrsikora, Assigned: mcmanus)

Tracking

44 Branch
mozilla44
Points:
---

Firefox Tracking Flags

(firefox44 fixed)

Details

(Whiteboard: [spdy])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.101 Safari/537.36

Steps to reproduce:

Connect to a server (localhost, sorry) running nginx-1.9.4 (with SPDY/3.1) with ngx_brotli module.


Actual results:

Firefox didn't send "accept-encoding" header (even though it's displayed in Developer Tools). It was fine to skip it when only gzip was supported, since SPDY spec requires clients to support it, but now that Brotli is also supported, Firefox needs to send it.


Expected results:

Firefox should send "accept-encoding: gzip, deflate, br" header.

Updated

3 years ago
Component: Untriaged → Networking: HTTP
Product: Firefox → Core
(Assignee)

Comment 1

3 years ago
I guess so - for the most part spdy is waiting to die and we don't add new features to it.. but in this case the feature shouldn't be transport version specific.

thanks for noticing.
Assignee: nobody → mcmanus
Whiteboard: [spdy]
(Assignee)

Comment 3

3 years ago
Created attachment 8675295 [details] [diff] [review]
enable brotli on spdy
Attachment #8675295 - Flags: review?(hurley)
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8675295 - Flags: review?(hurley) → review+
https://hg.mozilla.org/mozilla-central/rev/c23714f8078b
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox44: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
You need to log in before you can comment on or make changes to this bug.