Tree style tabs prevents tabs from being restored

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
--
critical
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: sfink, Unassigned)

Tracking

({addon-compat, dataloss, regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
The nightlies as of a week or two ago have completely broken session restore for me, when TST is enabled. It always comes up with no tabs. I kept copying back an old sessionstore.js, and it just deleted it.

It happens 100% reproducibly on my current nightly (2014-10-16). I feel like the first one it broke on was probably about 2 weeks old now.

I have the latest TST from amo installed (0.15.20150902901).

If I disable TST, all my tabs come back. (Or rather, restarting preserves tabs, and shutting down + copying in an old sessionstore.js + starting gives me the tabs from that sessionstore.js.)
Is there any interesting error message in the browser console?
Flags: needinfo?(sphink)
(Reporter)

Comment 2

2 years ago
(In reply to David Rajchenbach-Teller [:Yoric] (use "needinfo") from comment #1)
> Is there any interesting error message in the browser console?

Yes, very interesting. Forgive me for not cutting & pasting it, but it was an error about Components.utils. Which, it turns out, is only for a Greasemonkey compatibility patch that I don't need. If I create a pref "extensions.treestyletab.compatibility.Greasemonkey" set to false, then the error goes away.

And yet, my tabs still don't restore. On startup, the only message I see is:

TSTBrowser::restoreTree
  level = 1
  tabsToRestore = 1

which seems to imply that it's happily finding a single about:blank tab and restoring it.

This does look to be some sort of compatibility problem with TST, like maybe it's seeing the list of tabs from before restore happens and preventing the real restore from running. Or something.
Flags: needinfo?(sphink)

Comment 3

2 years ago
I'm seeing this with a current version of TST. Perhaps we are seeing https://github.com/piroor/treestyletab/issues/955 which was filed 18 days ago.

Error console has
TypeError: TreeStyleTabConstants is undefined content-utils-autohide.js:87:2
treestyletab: doPatching: [object XULElement]._setEffectAllowedForDataTransfer is missing! utils.js:324:0
ReferenceError: gSessionHistoryObserver is not defined windowHelper.js line 22 > eval:160:5

I also see the hamburger not function, which is https://github.com/piroor/treestyletab/issues/956

Does the nightly will work for you?  (I'm going to try it) http://piro.sakura.ne.jp/xul/xpi/nightly/
Severity: normal → major

Comment 4

2 years ago
http://piro.sakura.ne.jp/xul/xpi/nightly/ did not help me. 
FF 44.0a1 2015-09-29

10-07 hamburger works
10-08 hamburger fails

Comment 5

2 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #4)
> http://piro.sakura.ne.jp/xul/xpi/nightly/ did not help me. 
> FF 44.0a1 2015-09-29
> 
> 10-07 hamburger works
> 10-08 hamburger fails

and the session restore likewise.

HOWEVER, I had to go to extra lengths to successfully install the nightly version of TST - why I do not know. Removed TST from addons, then installed the nightly.  Now session restore and hamburger works with today's Firefox nightly 11-02

Updated

2 years ago
Duplicate of this bug: 1221366

Comment 7

2 years ago
approx regression range http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2015-10-07%2003:05:00&enddate=2015-10-08%2003:05:00

more reports of lost sessions (not all confirmed to involve TST):
bug 1217904
bug 1221467 implicates Multiple Tabs Handler addon
bug 1216292 (pinned tabs)
Severity: major → critical
Keywords: dataloss, regression
Keywords: addon-compat

Comment 8

2 years ago
bug query http://mzl.la/1NftiAd for safe keeping - lest I should lose yet another set of session tabs

Comment 9

2 years ago
Unfortunately I must qualify my previous comments, that my sessionstore may have been impacted by the Session Manager addon which was broken for such a long time that I forgot I had it installed. I don't have time to retest anything without session manager right now.

Comment 10

2 years ago
Steve are you still broken?
If not, is there a bug# for this at TST?
Flags: needinfo?(sphink)
(Reporter)

Comment 11

2 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #10)
> Steve are you still broken?
> If not, is there a bug# for this at TST?

No. I just updated to the 2015-11-30 nightly and reinstalled TST from AMO. It restored all my tabs, though it lost the saved tree structure (all of the saved tabs became toplevel.)

So this WFM now.
Flags: needinfo?(sphink)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.