Closed Bug 1215755 Opened 4 years ago Closed 4 years ago

TEST-UNEXPECTED-FAIL | Unhandled exception in test_interface_maplikesetlikeiterable | error: Unresolved type '<unresolved scope>::IterableIterator'

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla44
Tracking Status
firefox44 --- fixed

People

(Reporter: ewong, Assigned: bzbarsky)

References

Details

Attachments

(1 file)

Getting this on a SeaMonkey Linux32 comm-central build:

Starting test /builds/slave/c-cen-t-lnx/build/mozilla/dom/bindings/test/../parser/tests/test_interface_maplikesetlikeiterable.py
TEST-UNEXPECTED-FAIL | Unhandled exception in test test_interface_maplikesetlikeiterable: error: Unresolved type '<unresolved scope>::IterableIterator'., <unknown> line 2:15
               interface Foo1 {
               ^
Finished test /builds/slave/c-cen-t-lnx/build/mozilla/dom/bindings/test/../parser/tests/test_interface_maplikesetlikeiterable.py

Not sure what's going on here.

Filing against :qdot (as per convo on irc).
Hmm.  The confusing thing to me is how this test is possibly passing anywhere.  For iterable interfaces, we output something that "implements IterableIterator", but that interface is not defined in this test...  So we need to define it in there.

But again, how is the tree possibly green anywhere?   Do we not normally run the webidl parser tests on tbpl?  Wes, do you know who might know that?
Flags: needinfo?(wkocher)
This is really weird.  I can reproduce the fail by doing this:

  mach webidl-parser-test

I get the failure above.

But if I run it via "make -C $objdir/dom/bindings check" then the test passes.
> But if I run it via "make -C $objdir/dom/bindings check" then the test passes.

Er, no, it does not pass.  It outputs TEST-UNEXPECTED-FAIL as it should.

In fact I see this in logs on tbpl.  For example http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-linux/1445045490/mozilla-inbound-linux-bm91-build1-build1992.txt.gz has this bit:

19:01:44  WARNING - TEST-UNEXPECTED-FAIL | Unhandled exception in test test_interface_maplikesetlikeiterable: error: Unresolved type '<unresolved scope>::IterableIterator'., <unknown> line 2:15

So why the heck is the tree green?

Of course I see some other TEST-UNEXPECTED-FAIL in that log as well, from other make check testsuites...
I've got nothing. :(

Thought I saw philor mention he might maybe know something possibly related to this on IRC tonight, but that might've been about something else. Passing the ni? on to him.
Flags: needinfo?(wkocher) → needinfo?(philringnalda)
The needinfo flag isn't everything that's wrong with Mozilla in the modern era, but it's sure emblematic of an awful lot of it.
Flags: needinfo?(philringnalda)
OK, I spun that problem off into bug 1215819.  Will post a patch for this bug in a bit (probably Monday morning).
Sorry this is so large...  I decided it would be better to just not do this implements statement thing, since that keeps the parser from depending on our actual set of webidl files.  But even once I fixed that there were a bunch of failures in the test, so the rest of the patch is about fixing up those.  The only really substantive hunk is the second one of dom/bindings/parser/WebIDL.py
Attachment #8675711 - Flags: review?(kyle)
Assignee: kyle → bzbarsky
Status: NEW → ASSIGNED
Comment on attachment 8675711 [details] [diff] [review]
Change the Web IDL parser to just put a next() method in iterator interfaces instead of using an additional IterableIterator interface.  Fix up the other test failures in test_interface_maplikesetlikeiterable.py while I'm here

Review of attachment 8675711 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.

::: dom/bindings/parser/WebIDL.py
@@ +739,5 @@
>                      raise WebIDLError("%s declaration used on "
>                                        "interface that already has %s "
>                                        "declaration" %
>                                        (member.maplikeOrSetlikeOrIterableType,
> +                                       self.maplikeOrSetlikeOrIterable.maplikeOrSetlikeOrIterableType),

Nit: indent
Attachment #8675711 - Flags: review?(kyle) → review+
Ignore indent nit, splinter was making it look weird in review but it seems to have come out ok.
Duplicate of this bug: 1216348
https://hg.mozilla.org/mozilla-central/rev/a711f6884896
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.