"Paste As Quotation" label and command missing from Edit menu

VERIFIED FIXED in mozilla0.9.8

Status

--
major
VERIFIED FIXED
17 years ago
5 years ago

People

(Reporter: neil, Assigned: neil)

Tracking

({regression})

Trunk
mozilla0.9.8
x86
All
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
When Blake Ross added the "Paste As Quotation" menuitem to the compose context
menu he duplicated the id which means that the Edit/Paste As Quotation menuitem
doesn't overlay any more. Instead there is a "blank" menuitem.
Seen on linux 2002012308 also.
OS: Windows 95 → All
(Assignee)

Comment 2

17 years ago
Oh, and the "Paste as Quotation" context item doesn't update when the menu opens.
(Assignee)

Comment 3

17 years ago
Created attachment 66266 [details] [diff] [review]
Proposed patch
(Assignee)

Comment 4

17 years ago
IMHO this should go in to 0.9.8 as it is a major regression.
Assignee: ducarroz → neil
Keywords: patch, regression, review
Target Milestone: --- → mozilla0.9.8

Updated

17 years ago
Blocks: 115520

Comment 5

17 years ago
Hmm...bleh. Overlays suck for just this reason.

How about making a command, though, so we don't have to duplicate the dtd 
entities and stuff?

Updated

17 years ago
QA Contact: sheelar → olgam
(Assignee)

Comment 6

17 years ago
commands don't have accesskeys :-(

Anyway the fix is in the style of the rest of the context menu.

Comment 7

17 years ago
Commands don't "have" (broadcast?) accesskeys? Now that's a mistake.  We should
really use a broadcaster but I'll sr= this since Asa is coercing me, and he's a
manager, which means he 0w/\/z me.
(Assignee)

Comment 8

17 years ago
Filed bug 122201 on the access key issue.

Comment 9

17 years ago
Comment on attachment 66266 [details] [diff] [review]
Proposed patch

r=timeless [noting blake's sr=]
Attachment #66266 - Attachment description: Propsed patch → Proposed patch
Attachment #66266 - Flags: superreview+
Attachment #66266 - Flags: review+

Comment 10

17 years ago
a=asa (on behalf of drivers) for checkin to 0.9.8
Keywords: mozilla0.9.8+
Checked into the 0.9.8 branch.

Comment 12

17 years ago
Is this fixed?

Comment 13

17 years ago
damn I am stupid. It's only on the branch... Sorry forget my former post.
(Assignee)

Comment 14

17 years ago
I think it did get checked into the trunk.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 15

17 years ago
Verified on Win2K, Linux, Mac OSX - trunk build 02-04-2002 
Status: RESOLVED → VERIFIED
(Assignee)

Comment 16

17 years ago
Blake, while I know you would like the context menu to get its labels and
accesskeys from commands most of these commands are actually in
utilityOverlay.xul and I'm a bit wary of touching that in case it breaks other
windows e.g. History.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.