sorting mail by label reversed (unlabled unread/read is reversed)

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
enhancement
RESOLVED WORKSFORME
16 years ago
11 years ago

People

(Reporter: Ivan Tarapcik, Assigned: Sean Su)

Tracking

Trunk
mozilla1.2alpha

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Sorting of messages by label is reversed in build 20020122, in opposite to some 
1-2 week older build. 

Now sorting works in unlogical way where new messages are on top of the list 
and labeled messages are on bottom of the list. (message list sorted by label 
UP). So I either see new incoming messages when cursor is on top, or labeled 
important messages when cursor is on bottom of the list.

Comment 1

16 years ago
I believe you're describing the intended sort --> see bug 115689.

By New messages, you mean new and unlabeled messages, right? Or are you
assigning label via filter to new messages?
Assignee: sspitzer → ssu
QA Contact: esther → laurel

Comment 2

16 years ago
I have read these comments as well as bug 115689, and there is definitely 
something broken with the sorting (currently using 2002021203). The problem I 
am seeing is that when the labeled messages appear at the top, the 
newest/unread messages appear at the bottom, and vice versa. I believe this is 
what the first poster was pointing out; the order Labeled then Unlabeled is 
correct, but the sorting by date and/or status is wrong in that it puts the 
labeled messages at one end and the newest and unread messages at the other.

For example:

Message 1 02/10/2002 (Labeled)
Message 2 02/11/2002 (unlabeled/read)
Message 3 02/12/2002 (unlabeled/read)
Message 4 02/14/2002 (Unread)


This does not make any rational sense. What we *should* be seeing is:

Message 1 02/10/2002 (Labeled)
Message 4 02/14/2002 (Unread)
Message 3 02/12/2002 (unlabeled/read)
Message 2 02/11/2002 (unlabeled/read)

Where you have labeled messages at the top, then unread, then sort from most 
recent to oldest if descending, or oldest, unread, labeled if ascending.

This is extremely irritating.

-Chance

Comment 3

16 years ago
Nearly two months later, this bug is still UNCONFIRMED, with no severity,
priority, or target milestone even set for it yet... is there anybody out there?

Comment 4

16 years ago
I don't believe there was any intended secondary sort except by date within
label type.  Sort by label then other status is what you're wanting, correct?  A
mix of sorting on label and status?

Comment 5

16 years ago
Or rather a mix of sort on label and read/unread, not necessarily including
status(replied,forwarded, etc.).

Comment 6

16 years ago
confirming as enhancement request
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: sorting mail by label reversed → sorting mail by label reversed (unlabled unread/read is reversed)

Comment 7

16 years ago
Yes, I suppose you could think of it as a "secondary sort"... what I am getting
at here is illustrated in (cringe) Outlook Express: if you sort messages by,
say, "flagged", you will get the flagged messages at the top, in ascending order
(newest to oldest). Then, the rest of your mail will also be in ascending order,
by date, rather than in reverse-sorted, as Mozilla currently does.

1. Labeled Messages
2. Newest non-labeled messages
3. Oldest non-labeled messages

I think this should be considered more substantial than an "enhancement
request", however, as it is not the behavior that the typical user (who, odds
are, has been using Outlook) will expect. It is counter-intuitive that the
labeled messages would appear at the top and then the remainder of the messages
would be reverse-sorted such that unread/most recent messages appear at the
other end.

It can't be that hard to add a secondary sort. And it would win alot of people
over to Mozilla Mail. Little things like this are what makes all the difference.

-Chance

Comment 8

16 years ago
This is not just an enchancment request, because the way it does it currently,
sorting by label then date, its sorting by date in the wrong order. (labeled are
grouped next to oldest messages instead of newest). So thats definatly a bug,
the ability to set secondary, trinary etc sorts is what yall seem to want but
not what the original bug was about.   File secondary bug??

Comment 9

16 years ago
I would be ecstatic if they would just address the ass-backwards sort by date
problem that this was originally about... a secondary sort implementation would
be great, but the main problem is the reversed read/unread which makes sorting
by label useless.

I agree that this problem is more than an "enhancement request".

Comment 10

16 years ago
No, don't file another bug.  This one stands.
Severity: enhancement → normal

Comment 11

16 years ago
OS = "other"? Shouldn't that be "All"?
Version="other"?

Anyone care to offer a wild guess as to when, or if, this bug will be fixed?

(sound of crickets in the distance)

Is there anybody out there?


-Chance

Comment 12

16 years ago
It is not slated for a fix milestone. Maybe Sean (assignee) can comment on his
take on the bug, but as it stands now it is not in the fix list for the next
release.  
(Assignee)

Comment 13

16 years ago
platforms should be all because this affects labels on all platforms.  This
might be as simple as sorting the labels in a reverse manner than how they are
being done right now.  I'll have to take a look at the sort routine's filtering
code that filters out the labels to be sorted in a special way.

adding nsbeta1 to see what adt people think about this bug.
Severity: normal → enhancement
Status: NEW → ASSIGNED
Keywords: nsbeta1
OS: other → All
Hardware: PC → All

Comment 14

16 years ago
Discussed in mail news bug meeting. Decided to minus this bug.
Keywords: nsbeta1 → nsbeta1-
Target Milestone: --- → mozilla1.2alpha

Comment 15

16 years ago
"Decided to minus this bug."

What does that mean? Does the Target Milestone being set to mozilla1.2alpha mean
that it is going to be a long, long time before this is fixed?

Comment 16

15 years ago
*** Bug 129202 has been marked as a duplicate of this bug. ***

Comment 17

15 years ago
Is this going to be addressed? Sorry, this sorting thing is a pet peeve...

Comment 18

14 years ago
This bug is very similar to bug 238631.  As I posted there:

An Ascending sort by Unread puts the Unread messages at the bottom, and an 
Ascending sort by Date puts the newest (presumably most important) messages at 
the bottom.

Therefore, Ascending sort by Label should put the Important messages at the 
bottom, and the unlabelled at the top -- reversing the current sort order.

Note that the secondary sort criterion is not date, but "Order Received" which 
often but not always corresponds to date.  This bug could be mitigated by 
implementing multi-criterion sort (bug 57898).
Product: Browser → Seamonkey

Comment 19

11 years ago
With the replacement of Labels by Tags, we now have untagged messages placed at the bottom of the sort (top of the pane in an Ascending sort, bottom of the pane in a Descending sort), so the unique part of this bug is addressed.  It seems, tho, that sorting by tag puts them in alphabetical order of the tags, rather than order of importance; that's a different issue.

Multi-criterion sort is bug 57898 (bug 254128 for Thunderbird).
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.