Closed Bug 1215911 Opened 4 years ago Closed 4 years ago

[Browser] The "reload" button can be placed on top of the URL when the URL is too long

Categories

(Firefox OS Graveyard :: Gaia::System::Browser Chrome, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-master --- verified

People

(Reporter: julienw, Assigned: apastor)

Details

(Whiteboard: [systemsfe])

Attachments

(3 files)

Attached image 2015-10-18-01-15-16.png
This happened on the website http://internetactu.blog.lemonde.fr/2015/10/17/faut-il-prendre-leffondrement-au-serieux/ but when I try to go there directly the bug does not happen.

Maybe we can have a testcase with a URL that has no <title> and a long domain name.

I'm not sure how I got to this situation for this specific website.

See attachment.
Whiteboard: [systemsfe]
blocking-b2g: 2.5? → 2.5+
I'm unfortunately not able to reproduce this.

The (desired) URL truncation occurs due to the following CSS rule[1]:

.chrome-combined.maximized .title {
  width: calc(100% - 3.2rem);
}

... which leads me to believe that somehow, AppChrome's 'maximized' style didn't get set in Julien's screenshot. Manually removing that style override in WebIDE results in the same glitch seen here.

However, I've been unable to coerce the AppChrome to reproduce this glitch in practice. Setting qawanted to see if anyone else has better luck.

[1]: https://github.com/mozilla-b2g/gaia/blob/master/apps/system/style/chrome/chrome.css#L180
Keywords: qawanted
Using the following link: 
http://internetactu.blog.lemonde.fr/2015/10/17/faut-il-prendre-leffondrement-au-serieux/ 

I was NOT able to repro this issue using the Aries Master and Flame 2.5. 
Result: The reload button is not appearing within the hyper link box. Recommending steps wanted tag and leaving qawanted for other testers to attempt. 

Environmental Variables:
Device: Aries 2.5
BuildID: 20151019104907
Gaia: f75bd584aca0a751a5bed115800250faa8412927
Gecko: d3e87bb40753327550143ba8ac8ee27b300cd4a9
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Environmental Variables:
Device: Flame 2.5 Kk Fullflash (319mb)
BuildID: 20151019030208
Gaia: f75bd584aca0a751a5bed115800250faa8412927
Gecko: 1a157155a4fe0074b3d03b54fe9e466472c2cd56
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Marcus, looking at the code, can you think of a path that could lead to not setting maximized ?

I agree I couldn't reproduce when trying to reproduce -- on the same build that I saw this happening. It was also not the first time I saw it happening BTW.

I'm quite sure I entered the window from Twitter, in case that helps. (but when I tried again by tapping the same link, it didn't happen, so I think this is a race).
Assignee: nobody → apastor
Priority: -- → P2
(In reply to Marcus Cavanaugh [:mcav] (Mozilla SF) from comment #1)
> I'm unfortunately not able to reproduce this.
> 
> The (desired) URL truncation occurs due to the following CSS rule[1]:
> 
> .chrome-combined.maximized .title {
>   width: calc(100% - 3.2rem);
> }
> 
> ... which leads me to believe that somehow, AppChrome's 'maximized' style
> didn't get set in Julien's screenshot. Manually removing that style override
> in WebIDE results in the same glitch seen here.
> 
> However, I've been unable to coerce the AppChrome to reproduce this glitch
> in practice. Setting qawanted to see if anyone else has better luck.
> 
> [1]:
> https://github.com/mozilla-b2g/gaia/blob/master/apps/system/style/chrome/
> chrome.css#L180

If that was the case (maximized class not set), the chrome would appear as collapsed in the screenshot. I believe this could happen if, somehow, the 'collapsible' class in the appWindow gets removed.

https://github.com/mozilla-b2g/gaia/blob/master/apps/system/style/chrome/chrome.css#L827

I'll try to get STR for this.
Julien, do you have the id of the build you used? I suspect this comes from Pinning the Web removing the 'collapsible' class at some point, but that's probably already fixed.
Flags: needinfo?(felash)
Build id is 20151002103912 (current dogfooding build -- already some weeks late for sure).

If you have an idea of how this could happen I can try to reproduce.
Flags: needinfo?(felash)
I think I got STR for that build:

1.- Search 'long domain name' in google
2.- Pin the site on the results page
3.- Close all windows
4.- Open the pinned site from the homescreen
5.- Click on a result that says something like 'Congratulations of finding the world longest domain name'

Julien, can you confirm that this doesn't happen anymore in master?

Thanks!
Flags: needinfo?(felash)
Ups, I think this still happens. I'll take a look
Flags: needinfo?(felash)
So, I have it reproduced on my phone right now (still old build).

Inspecting it, I definitely confirm what Alberto says in comment 4: the rule he links to overrides the rule "calc(100% - 3.2rem)".


I also confirm that the chrome does not collapse when I scroll like it does in other screens. So that's another visible symptom for the issue.

And I think the issue is when we go out of the pinned site while the pinned site has a collapsed chrome. If we open the chrome first and then navigate, it doesn't reproduce.

Here is my rough STR:
1. Open a pinned site (in my case: lemonde.fr). This also happens if we navigate to the same URL than a pinned site.
2. While the chrome is still closed, follow a link out of the site. (in the case of lemonde.fr, that's all links that have "POST DE BLOG" (I'm sure you'll figure out what this means :D).
=> on this website, you won't be able to collapse the chrome by scrolling. The second symptom is what I showed in attachment 8675379 [details].


Now let me try on a more recent master.
OK I definitely reproduce using my STR from yesterday's build (build id: 20151019030208, gaia commit: f75bd584).
Comment on attachment 8676355 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/32603

Looks good to me, and thanks for the tests.
Attachment #8676355 - Flags: review?(mhenretty) → review+
master: https://github.com/mozilla-b2g/gaia/commit/2c95eeee364b38e626c386652bd3128960a55208
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1216086
Removing qawanted since bug was marked fixed.

I can't repro the bug on Aries using steps at comment 7 or comment 9 though.

Not reproducible on:
Device: Aries 2.5
BuildID: 20151020162500
Gaia: 3491a49da4d4ce45b8a682e95d0ce68892c2b8ea
Gecko: f7b746b4e91307448cb0746a41f677bfc23908b0
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 7.

Actual results: The "reload" button shows normally and doesn't overlay on the top of the URL when the URL is too long.
See attachment: verified_Flame_v2.5.3gp
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20151029150245
Gaia Revision          91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gaia Date              2015-10-28 20:32:15
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1fbc958f75576446a57cf93406db87b51b12911d
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151029.182818
Firmware Date          Thu Oct 29 18:28:30 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Pass)
Build ID               20151030012032
Gaia Revision          91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gaia Date              2015-10-28 20:32:15
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6d1e12f5725b56453e368b960e873261e0d48b5a
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151030.003706
Firmware Date          Fri Oct 30 00:37:14 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.